Bug 172275 - system-config-lvm crashes on startup
system-config-lvm crashes on startup
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: system-config-lvm (Show other bugs)
4
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Stanko Kupcevic
Jim Parsons
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-02 02:16 EST by bob mckay
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-18 14:55:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bob mckay 2005-11-02 02:16:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
system-config-lvm crashes on startup. The problem seems similar to 169860, but I'm not sure if it's the same problem.

Version-Release number of selected component (if applicable):
system-config-lvm-0.9.32-1.0

How reproducible:
Always

Steps to Reproduce:
1.start up system-config-lvm
2.
3.
  

Actual Results:  crashes:
[rim@sc log]$ system-config-lvm
Traceback (most recent call last):
  File "/usr/share/system-config-lvm/system-config-lvm.py", line 133, in ?
    runFullGUI()
  File "/usr/share/system-config-lvm/system-config-lvm.py", line 118, in runFullGUI
    blvm = baselvm(glade_xml, app)
  File "/usr/share/system-config-lvm/system-config-lvm.py", line 72, in __init__    self.volume_tab_view = Volume_Tab_View(glade_xml, self.lvmm, self.main_win)
  File "/usr/share/system-config-lvm/Volume_Tab_View.py", line 129, in __init__
    self.prepare_tree()
  File "/usr/share/system-config-lvm/Volume_Tab_View.py", line 224, in prepare_tree
    pv_list = self.model_factory.query_PVs_for_VG(vg_name)
  File "/usr/share/system-config-lvm/lvm_model.py", line 294, in query_PVs_for_VG
    pv_s = self.query_PVs()
  File "/usr/share/system-config-lvm/lvm_model.py", line 275, in query_PVs
    words[P_VG_NAME_COL],
IndexError: list index out of range


Expected Results:  runs normally

Additional info:

This is almost certainly a result of some recent work I had done with lvm. I added a new usb drive, and used system-config-lvm to add it to the pool for LogVol00. This seems to have been a mistake. The next time I rebooted the system to win/XP, it booted fine, but then when I rebooted to fc4, it complained right at the start of the boot process that it could not find an element of VolGroup00 (namely the new drive), generating a kernel panic. I was unable to get fc4 to boot at all. I'm guessing that this is because the boot sequence meant that it was trying to mount VolGroup00 before the usb drivers had been installed. After repeated attempts, I resorted to using vgreduce to remove the physical drive from VolGroup00. That enabled fc4 to reboot, but now system-config-lvm won't run (am I right in guessing that this may be because the lvm tables and its own internal tables are now inconsistent?)
Comment 1 bob mckay 2005-11-02 03:14:50 EST
Sorry, now explained. The crash occurred because VolGroup00 was inconsistent -
it was marked as not including the deleted physical volume, but the physical
volume still considered itself part of VolGroup00. Once this was repaired,
system-config-lvm works fine. (I guess this could be left as a request for
enhancement, ie that system-config-lvm check consistency, and if it detects an
inconsistency, fail gracefully with a message to the user explaining what the
inconsistency is - ideally, even what to do about it)

Note You need to log in before you can comment on or make changes to this bug.