Bug 1722878 - Changing storage type makes impossible to delete config.imageregistry.operator.openshift.io
Summary: Changing storage type makes impossible to delete config.imageregistry.operato...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image Registry
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 4.3.0
Assignee: Ricardo Maraschini
QA Contact: Wenjing Zheng
URL:
Whiteboard:
Depends On:
Blocks: 1759159
TreeView+ depends on / blocked
 
Reported: 2019-06-21 14:47 UTC by Oleg Bulatov
Modified: 2020-01-23 11:04 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: after changing the storage type in the image registry operator's configuration, the previous and new storage types would appear in the operator's status Consequence: the image registry operator fails to tear itself down when the image registry operator's configuration is deleted Fix: only one storage type is allowed to appear in the operator's status Result: the image registry operator can be removed after changing the storage used by the image registry
Clone Of:
: 1759159 (view as bug list)
Environment:
Last Closed: 2020-01-23 11:04:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift cluster-image-registry-operator pull 394 None closed Bug 1722878: reseting configured storages before DeepCopy() 2020-04-02 09:09:53 UTC
Red Hat Product Errata RHBA-2020:0062 None None None 2020-01-23 11:04:41 UTC

Description Oleg Bulatov 2019-06-21 14:47:37 UTC
Description of problem:

We you decide to change your storage (for example, from S3 to PVC), the information about the old storage doesn't get evicted from the config.imageregistry.operator.openshift.io Status field.

As a result, finalization of the config resource fails because it sees two configurations.

Steps to Reproduce:
1. Create a cluster on S3.
2. Wait until the image registry gets deployed.
3. oc edit config.imageregistry.operator.openshift.io: change spec.storage so that it uses another storage
4. oc delete config.imageregistry.operator.openshift.io

Actual results:

The resource cannot be deleted.

Expected results:

The resource is deleted.

Comment 3 XiuJuan Wang 2019-10-16 10:35:44 UTC
Could reproduce this in 4.2 version 4.2.0-0.nightly-2019-10-11-230724
Verified in 4.3.0-0.nightly-2019-10-15-180816.
Steps:
1. Create a cluster based on aws platfrom which used s3 storage default.
2. Wait until the image registry gets deployed.
3. oc edit config.imageregistry.operator.openshift.io: change spec.storage to use pvc.
4. Check config.imageregistry again, the status.storage only have one method storage.
5. Delete config.imageregistry, it can be deleted quickly.

Comment 5 errata-xmlrpc 2020-01-23 11:04:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.