Bug 1722937 - [Regression] Unable to capture metrics from Azure
Summary: [Regression] Unable to capture metrics from Azure
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: C&U Capacity and Utilization
Version: 5.10.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.10.6
Assignee: Alexander Zagaynov
QA Contact: Nandini Chandra
Red Hat CloudForms Documentation
URL:
Whiteboard:
Depends On: 1671580
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-06-21 18:19 UTC by Satoe Imaishi
Modified: 2019-10-30 20:00 UTC (History)
9 users (show)

Fixed In Version: 5.10.6.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1671580
Environment:
Last Closed: 2019-07-02 04:33:28 UTC
Category: ---
Cloudforms Team: Azure
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:1644 None None None 2019-07-02 04:33:31 UTC

Comment 2 CFME Bot 2019-06-21 18:26:34 UTC
New commit detected on ManageIQ/manageiq-providers-azure/hammer:

https://github.com/ManageIQ/manageiq-providers-azure/commit/46d1cb3a2f14afb922e6a16cf582a7479e62f5d9
commit 46d1cb3a2f14afb922e6a16cf582a7479e62f5d9
Author:     Daniel Berger <dberger@redhat.com>
AuthorDate: Fri Jun 21 13:27:04 2019 -0400
Commit:     Daniel Berger <dberger@redhat.com>
CommitDate: Fri Jun 21 13:27:04 2019 -0400

    Merge pull request #335 from AlexanderZagaynov/BZ-1671580_azure_metrics

    metrics fix and refactoring

    (cherry picked from commit 42764d2bc63e069de4928569f2e9916b16bb8fbb)

    Fixes https://bugzilla.redhat.com/show_bug.cgi?id=1722937

 app/models/manageiq/providers/azure/cloud_manager/metrics_capture.rb | 357 +-
 spec/models/manageiq/providers/azure/cloud_manager/metrics_capture_spec.rb | 4 +-
 2 files changed, 177 insertions(+), 184 deletions(-)

Comment 3 Nandini Chandra 2019-06-25 20:55:37 UTC
Verified in 5.10.6.1

Comment 5 errata-xmlrpc 2019-07-02 04:33:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:1644


Note You need to log in before you can comment on or make changes to this bug.