Bug 172303 - make xconfig fails on -lqt on X86_64
make xconfig fails on -lqt on X86_64
Status: CLOSED DUPLICATE of bug 137926
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2005-11-02 10:38 EST by Sammy
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-11-04 16:26:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Sammy 2005-11-02 10:38:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.4; Linux; X11; en_US) KHTML/3.4.92 (like Gecko)

Description of problem:
When I do "make xconfig" either from the devel build tree or after from the BUILD 
directory source created by the src.rpm I get the following: 
# make xconfig 
  HOSTCC  scripts/basic/fixdep 
  HOSTCC  scripts/basic/split-include 
  HOSTCC  scripts/basic/docproc 
  HOSTCC  scripts/kconfig/conf.o 
sed < scripts/kconfig/lkc_proto.h > scripts/kconfig/lkc_defs.h 's/P(\([^,]*\),.*/#define \1 
  HOSTCC  scripts/kconfig/kconfig_load.o 
  HOSTCC  scripts/kconfig/kxgettext.o 
  HOSTCC  scripts/kconfig/mconf.o 
  HOSTCC  scripts/kconfig/zconf.tab.o 
scripts/kconfig/zconf.tab.c:228:6: warning: "YYSTACK_USE_ALLOCA" is not defined 
scripts/kconfig/zconf.tab.c:852:5: warning: "YYMAXDEPTH" is not defined 
/usr/lib64/qt-3.3/bin/moc -i scripts/kconfig/qconf.h -o scripts/kconfig/qconf.moc 
  HOSTCXX scripts/kconfig/qconf.o 
  HOSTLD  scripts/kconfig/qconf 
/usr/bin/ld: cannot find -lqt 
collect2: ld returned 1 exit status 
make[1]: *** [scripts/kconfig/qconf] Error 1 
make: *** [xconfig] Error 2 
If I look into scripts/kconfig/.tmp_qtcheck the name and path are incorrect. The name 
should be qt-mt instead of qt and path should be /usr/lib64/qt-3.3/lib and not 

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install one of the latest kernel rpms on an x86_64 system 
2. go to kernel-devel tree and do "make xconfig" 

Additional info:
Comment 1 Dave Jones 2005-11-04 16:26:56 EST

*** This bug has been marked as a duplicate of 137926 ***

Note You need to log in before you can comment on or make changes to this bug.