Bug 17231 - XFree 4.0 Font server
Summary: XFree 4.0 Font server
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-09-04 09:10 UTC by fleury
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-14 17:40:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description fleury 2000-09-04 09:10:20 UTC
Well,

This is not a bug, I just submit an enhancement (IMHO).

I tried to use the XFree 4.0 TrueType font module (freetype and/or xtt) and
I extend it to all fonts.

3 steps:

1) I stopped the xfs server 

2) I added :

In the "File" section:
	FontPath "/usr/X11R6/lib/X11/fonts/misc:unscaled"
	FontPath "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
	FontPath "/usr/X11R6/lib/X11/fonts/misc"
	FontPath "/usr/X11R6/lib/X11/fonts/75dpi"
	FontPath "/usr/X11R6/lib/X11/fonts/Type1"
	FontPath "/usr/X11R6/lib/X11/fonts/Speedo"
	FontPath "/usr/X11R6/lib/X11/fonts/TrueType"

In the "Module" section:
	Load  "type1"
	Load  "speedo"
	Load  "freetype"
	Load  "bitmap"

3) I copy some true type fonts in /usr/X11R6/lib/X11/fonts/TrueType/ and
run "ttmkfdir" in this directory (this software is include in the rpm
package of freetype).

Finally, I restarted the X server.

All seems to work fine. I didn't notice anything wrong for the moment.

To my advice it's an improvement because, we can close the port 7100 and
shutdown one daemon (xfs) or even two (xfstt). Moreover, it is simpler to
configure because you just have to write in one file.

So, adding this feature to RedHat 7.0 could be an improvement.

Regards

Comment 1 Bernhard Rosenkraenzer 2001-01-24 19:40:24 UTC
We use xfs for this intentionally. It's not a security leak because it listens
on 127.0.0.1 only, and xfs handles TrueType fonts just fine if you mention the
directory in /etc/X11/xfs/config.


Note You need to log in before you can comment on or make changes to this bug.