Bug 172314 - compiler warning in linux-2.6-execshield.patch (mmap.c: warning: comparison of distinct pointer types lacks a cast)
compiler warning in linux-2.6-execshield.patch (mmap.c: warning: comparison o...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-02 13:00 EST by Marcin Garski
Modified: 2015-01-04 17:22 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-04 16:28:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcin Garski 2005-11-02 13:00:53 EST
Vanilla kernel 2.6.14, patched with linux-2.6-execshield.patch (revision: 1.1),
gives following warning durring compile on FC4:

CC      mm/mmap.o
mm/mmap.c: In function ‘arch_get_unmapped_exec_area’:
mm/mmap.c:1422: warning: comparison of distinct pointer types lacks a cast

The affected line is:
tmp = randomize_range(0x01000000, PAGE_ALIGN(max(mm->start_brk, 0x08000000)), len);
Comment 1 Marcin Garski 2005-11-02 13:02:54 EST
I file a bug in RH bugzilla because that line comes from linux-2.6-execshield.patch.

Note You need to log in before you can comment on or make changes to this bug.