Bug 1723432 - Broken dependency for python3-social-auth on Fedora 30
Summary: Broken dependency for python3-social-auth on Fedora 30
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-social-auth-app-flask-sqlalchemy
Version: 30
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Jeremy Cline
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-06-24 13:55 UTC by Michal Konecny
Modified: 2019-07-06 04:09 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-06 04:09:18 UTC


Attachments (Terms of Use)

Description Michal Konecny 2019-06-24 13:55:53 UTC
Description of problem:
I can't install `python3-social-auth-app-flask-sqlalchemy` on Fedora 30.
It is failing with:

```
Error: 
 Problem 1: package python3-social-auth-app-flask-sqlalchemy-1.0.1-4.fc30.noarch requires python3.7dist(social-auth-core) >= 1.0.0, but none of the providers can be installed
  - package python3-social-auth-app-flask-sqlalchemy-1.0.1-4.fc30.noarch requires python3dist(social-auth-core) >= 1.0.0, but none of the providers can be installed
  - conflicting requests
  - nothing provides python3.7dist(defusedxml) >= 0.5.0rc1 needed by python3-social-auth-core-1.7.0-4.fc30.noarch
(try to add '--skip-broken' to skip uninstallable packages)
```

I tried this in Fedora 30 container image and on Fedora 30 Workstation.

Version-Release number of selected component (if applicable):


How reproducible:
Just try to install package on Fedora 30

Steps to Reproduce:
1. dnf install python3-social-auth-app-flask-sqlalchemy


Actual results:
```
Error: 
 Problem 1: package python3-social-auth-app-flask-sqlalchemy-1.0.1-4.fc30.noarch requires python3.7dist(social-auth-core) >= 1.0.0, but none of the providers can be installed
  - package python3-social-auth-app-flask-sqlalchemy-1.0.1-4.fc30.noarch requires python3dist(social-auth-core) >= 1.0.0, but none of the providers can be installed
  - conflicting requests
  - nothing provides python3.7dist(defusedxml) >= 0.5.0rc1 needed by python3-social-auth-core-1.7.0-4.fc30.noarch
(try to add '--skip-broken' to skip uninstallable packages)
```

Expected results:
Installation successful

Additional info:

Comment 1 Michal Konecny 2019-06-25 12:54:03 UTC
I noticed that this issue is gone on Rawhide.

Comment 2 Michal Konecny 2019-06-25 13:24:09 UTC
I tried it again on Rawhide today and it's not working anymore, but the issue is different than on F30:
```
Error: 
 Problem: package python3-social-auth-app-flask-sqlalchemy-1.0.1-4.fc30.noarch requires python3.7dist(social-auth-core) >= 1.0.0, but none of the providers can be installed
  - package python3-social-auth-app-flask-sqlalchemy-1.0.1-4.fc30.noarch requires python3dist(social-auth-core) >= 1.0.0, but none of the providers can be installed
  - package python3-social-auth-core-1.7.0-4.fc30.noarch requires python3dist(python3-saml), but none of the providers can be installed
  - conflicting requests
  - nothing provides python3.7dist(defusedxml) = 0.5.0 needed by python3-saml-1.3.0-4.fc30.noarch
```

I looked at https://src.fedoraproject.org/rpms/python3-saml/blob/f30/f/python3-saml.spec, but I don't see any hardcoded version of defusedxml, so I'm not sure why it is complaining.

Comment 3 Kevin Fenzi 2019-06-26 00:57:47 UTC
I fixed this in rawhide. If you like I can see about pushing to f30. 

Basically this dep is coming from the setup.py: 

        'defusedxml==0.5.0'

upstream has already relaxed this in git, but it's not in a current release ( see: https://github.com/onelogin/python3-saml/commit/064b7275fba1e5f39a9116ba1cdcc5d01fc34daa ) 

So, I relaxed it here and also updated to 1.6.0 (lots of bugfixes). 

Hopefully thats all ok.

Comment 4 Michal Konecny 2019-06-26 06:45:02 UTC
If you can push it to F30, I will be thankful.

Comment 5 Kevin Fenzi 2019-06-27 17:33:53 UTC
ok, f30 is fun... the issue I fixed in python3-saml isn't an issue in f30, instead the problem there is that python-social-auth-core has a requirement for 'defusedxml>=0.5.0rc1' and python-defusedxml-0.5.0 is available, but rpm doesn't see that as >= 0.5.0rc1, so it fails. 

So, I am relaxing that requirement to just '>=0.5.0' and that should fix things in f30 (in f31 there's a newer python-defusedxml, so it doesn't hit this).

Look for a update with that in a few minutes...

Comment 6 Fedora Update System 2019-06-27 17:44:23 UTC
FEDORA-2019-47c444bcfd has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-47c444bcfd

Comment 7 Fedora Update System 2019-06-28 18:25:30 UTC
python-social-auth-core-1.7.0-5.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-47c444bcfd

Comment 8 Fedora Update System 2019-07-06 04:09:18 UTC
python-social-auth-core-1.7.0-5.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.