Bug 1723545 - Directory Server 10 not RFC 4511 compliant
Summary: Directory Server 10 not RFC 4511 compliant
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: 389-ds-base
Version: 7.8
Hardware: All
OS: All
high
high
Target Milestone: rc
: ---
Assignee: mreynolds
QA Contact: RHDS QE
Marc Muehlfeld
URL:
Whiteboard:
Depends On:
Blocks: 1801705
TreeView+ depends on / blocked
 
Reported: 2019-06-24 19:00 UTC by Eugene Keck
Modified: 2020-04-24 14:27 UTC (History)
9 users (show)

Fixed In Version: 389-ds-base-1.3.10.1-2.el7
Doc Type: Bug Fix
Doc Text:
.Directory Server is RFC 4511-compliant when searching for the `1.1` and other attributes in one request To retrieve only a list of matching distinguished names (DN), LDAP users can search for the `1.1` special attribute. According to RFC 4511, if an LDAP client searches for the `1.1.` special attribute in combination with other attributes in one search request, the server must ignore the `1.1` special attribute. Previously, when a Directory Server user searched for the `1.1` special attribute and other attributes in the same search request, the server returned no attributes. This update fixes the problem. As a result, Directory Server is RFC 4511-compliant in the mentioned scenario.
Clone Of:
: 1801705 (view as bug list)
Environment:
Last Closed: 2020-03-31 19:46:14 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:1064 None None None 2020-03-31 19:46:55 UTC

Description Eugene Keck 2019-06-24 19:00:20 UTC
Description of problem:
When doing a search and adding 1.1 with attributes. Not returning attributes.  

Version-Release number of selected component (if applicable):
389-ds-base-1.3.8.4-23.el7_6.

How reproducible:
Always

Steps to Reproduce:
1. ldapsearch -LLLx -H ldap://127.0.0.1 -b "uid=admin,cn=users,cn=accounts,dc=example,dc=local" uid gecos 1.1

Actual results:
nothing

Expected results:
uid: admin
gecos: Administrator

Additional info:

3. A list containing only the OID "1.1" indicates that no
   attributes are to be returned.  If "1.1" is provided with other
   attributeSelector values, the "1.1" attributeSelector is
   ignored.  This OID was chosen because it does not (and can not)
   correspond to any attribute in use.

Comment 2 mreynolds 2019-08-02 18:36:06 UTC
Upstream ticket:
https://pagure.io/389-ds-base/issue/50530

Comment 3 mreynolds 2019-08-05 13:23:51 UTC
Fixed upstream

Comment 10 bsmejkal 2019-09-17 08:09:49 UTC
=============================================================================================== test session starts ===============================================================================================
platform linux -- Python 3.6.3, pytest-5.1.2, py-1.8.0, pluggy-0.13.0 -- /opt/rh/rh-python36/root/usr/bin/python3
cachedir: .pytest_cache
metadata: {'Python': '3.6.3', 'Platform': 'Linux-3.10.0-1090.el7.x86_64-x86_64-with-redhat-7.8-Maipo', 'Packages': {'pytest': '5.1.2', 'py': '1.8.0', 'pluggy': '0.13.0'}, 'Plugins': {'metadata': '1.8.0', 'html': '2.0.0'}}
389-ds-base: 1.3.10.1-2.el7
nss: 3.44.0-5.el7
nspr: 4.21.0-1.el7
openldap: 2.4.44-21.el7_6
cyrus-sasl: 2.1.26-23.el7
FIPS: disabled
rootdir: /mnt/tests/rhds/tests/upstream/ds/dirsrvtests, inifile: pytest.ini
plugins: metadata-1.8.0, html-2.0.0                                                                                                                                                                   

basic_test.py::test_search_req_attrs[attrs0-cn-False] PASSED                                                                                                                                                [ 20%]
basic_test.py::test_search_req_attrs[attrs1-cn-True] PASSED                                                                                                                                                 [ 40%]
basic_test.py::test_search_req_attrs[attrs2-nsUniqueId-True] PASSED                                                                                                                                         [ 60%]
basic_test.py::test_search_req_attrs[attrs3-cn-True] PASSED                                                                                                                                                 [ 80%]
basic_test.py::test_search_req_attrs[attrs4-cn-True] PASSED                                                                                                                                                 [100%]

================================================================================= 5 passed in 10.55s =============================================================================================================


Marking as VERIFIED.

Comment 15 errata-xmlrpc 2020-03-31 19:46:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1064


Note You need to log in before you can comment on or make changes to this bug.