Bug 172368 - Missing dependency: httpd
Missing dependency: httpd
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: httpd (Show other bugs)
4
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-03 08:25 EST by Jan Kratochvil
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-03 20:43:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jan Kratochvil 2005-11-03 08:25:42 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923 Galeon/1.3.21

Description of problem:
Missing BuildRequires: byacc


Version-Release number of selected component (if applicable):
httpd-2.0.54-10.2

How reproducible:
Always

Steps to Reproduce:
1. rpm -e byacc
2. rpmbuilb -bb httpd.spec


Actual Results:  yacc -d /home/lace/src/rpm/BUILD/httpd-2.0.54/modules/ssl/ssl_expr_parse.y
make[4]: yacc: Command not found
make[4]: *** [ssl_expr_parse.h] Error 127
make[4]: Leaving directory `/home/lace/src/rpm/BUILD/httpd-2.0.54/prefork/modules/ssl'
make[3]: *** [shared-build-recursive] Error 1
make[3]: Leaving directory `/home/lace/src/rpm/BUILD/httpd-2.0.54/prefork/modules/ssl'
make[2]: *** [shared-build-recursive] Error 1
make[2]: Leaving directory `/home/lace/src/rpm/BUILD/httpd-2.0.54/prefork/modules'
make[1]: *** [shared-build-recursive] Error 1
make[1]: Leaving directory `/home/lace/src/rpm/BUILD/httpd-2.0.54/prefork'
make: *** [all-recursive] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.78975 (%build)


Expected Results:  Successfully built package.


Additional info:
Comment 1 Joe Orton 2005-11-03 11:46:41 EST
When this fails, what is the output of:

  cd /home/lace/src/rpm/BUILD/httpd-2.0.54/prefork
  ls -l modules/ssl/ssl_expr_* ../modules/ssl/ssl_expr_*
Comment 2 Jan Kratochvil 2005-11-03 20:43:07 EST
Sorry, it was due to my patch of some httpd header and its dependencies causing
the rebuild. I should check it more thoroughly next time.

Note You need to log in before you can comment on or make changes to this bug.