Bug 1723715 - external display stops working
Summary: external display stops working
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: 30
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-06-25 08:33 UTC by Freddy Willemsen
Modified: 2019-07-09 18:29 UTC (History)
14 users (show)

Fixed In Version: xorg-x11-server-1.20.5-3.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-30 00:56:48 UTC


Attachments (Terms of Use)
xrandr output 1.20.4 (4.94 KB, text/plain)
2019-06-25 08:33 UTC, Freddy Willemsen
no flags Details
xrandr output 1.20.5 (3.21 KB, text/plain)
2019-06-25 08:34 UTC, Freddy Willemsen
no flags Details
journal output 1.20.4 (454.37 KB, text/plain)
2019-06-25 08:35 UTC, Freddy Willemsen
no flags Details
journal output 1.20.5 (470.24 KB, text/plain)
2019-06-25 08:35 UTC, Freddy Willemsen
no flags Details

Description Freddy Willemsen 2019-06-25 08:33:55 UTC
Created attachment 1584237 [details]
xrandr output 1.20.4

Description of problem:
When using xorg-x11-server-1.20.5 my external monitor (Dell U2515H) stays blank. xrandr/settings does see the monitor correctly but you can not show any content on it. I usually have the external monitor set to being the primary and the internal laptop (Dell Latitude E5570) display to secondary, below the primary. Tried removing monitors.xml and the external display shortly fires up but then goes blank again.

Version-Release number of selected component (if applicable):
xorg-x11-server-1.20.5

How reproducible:
Upgrade from xorg-x11-server-1.20.4 to xorg-x11-server-1.20.5

Steps to Reproduce:
1. dnf upgrade
2.
3.

Actual results:
External monitor stays blank


Expected results:
External monitor works as the primary display

Additional info:
Using an X11 session, not wayland. Tried xorg-x11-server-1.20.5.1 and xorg-x11-server-1.20.5.2.

Comment 1 Freddy Willemsen 2019-06-25 08:34:30 UTC
Created attachment 1584238 [details]
xrandr output 1.20.5

Comment 2 Freddy Willemsen 2019-06-25 08:35:03 UTC
Created attachment 1584239 [details]
journal output 1.20.4

Comment 3 Freddy Willemsen 2019-06-25 08:35:26 UTC
Created attachment 1584240 [details]
journal output 1.20.5

Comment 4 Kamil Páral 2019-06-26 07:23:17 UTC
I can confirm xorg-x11-server-Xorg-1.20.5-2.fc30 breaks external display functionality even for me. I have Benq BL2411 display and Thinkpad T480s laptop with this graphics:
00:02.0 VGA compatible controller [0300]: Intel Corporation UHD Graphics 620 [8086:5917] (rev 07)
I connect using HDMI->DVI adapter. I use X11 session.

If I connect the display, I see this in the journal:

Jun 26 09:08:19 phoenix /usr/libexec/gdm-x-session[1854]: (II) modeset(0): Allocate new frame buffer 3840x1200 stride
Jun 26 09:08:19 phoenix /usr/libexec/gdm-x-session[1854]: (EE) modeset(0): failed to set mode: Invalid argument
Jun 26 09:08:19 phoenix /usr/libexec/gdm-x-session[1854]: (II) modeset(0): EDID vendor "CMN", prod id 5321
Jun 26 09:08:19 phoenix /usr/libexec/gdm-x-session[1854]: (II) modeset(0): Printing DDC gathered Modelines:
Jun 26 09:08:19 phoenix /usr/libexec/gdm-x-session[1854]: (II) modeset(0): Modeline "1920x1080"x0.0  152.84  1920 2000 2060 2250  1080 1086 1094 1132 -hsync -vsync (67.9 kHz eP)

Notice the (EE) line. The display says "no signal detected".


If I revert to xorg-x11-server-Xorg-1.20.4-3.fc30 and connect the display I see this:

Jun 26 09:12:32 phoenix /usr/libexec/gdm-x-session[1861]: (II) modeset(0): EDID vendor "CMN", prod id 5321
Jun 26 09:12:32 phoenix /usr/libexec/gdm-x-session[1861]: (II) modeset(0): Printing DDC gathered Modelines:
Jun 26 09:12:32 phoenix /usr/libexec/gdm-x-session[1861]: (II) modeset(0): Modeline "1920x1080"x0.0  152.84  1920 2000 2060 2250  1080 1086 1094 1132 -hsync -vsync (67.9 kHz eP)
comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? termi>
Jun 26 09:12:33 phoenix /usr/libexec/gdm-x-session[1861]: (II) modeset(0): Allocate new frame buffer 3840x1200 stride
Jun 26 09:12:33 phoenix /usr/libexec/gdm-x-session[1861]: (II) modeset(0): EDID vendor "CMN", prod id 5321
Jun 26 09:12:33 phoenix /usr/libexec/gdm-x-session[1861]: (II) modeset(0): Printing DDC gathered Modelines:
Jun 26 09:12:33 phoenix /usr/libexec/gdm-x-session[1861]: (II) modeset(0): Modeline "1920x1080"x0.0  152.84  1920 2000 2060 2250  1080 1086 1094 1132 -hsync -vsync (67.9 kHz eP)

And the display works fine.


My software versions:
xorg-x11-server-Xorg-1.20.5-2.fc30.x86_64    
xorg-x11-server-Xwayland-1.20.5-2.fc30.x86_64 
xorg-x11-server-common-1.20.5-2.fc30.x86_64  
kernel-5.1.15-300.fc30.x86_64
mutter-3.32.2-2.fc30.x86_64
gnome-shell-3.32.2-2.fc30.x86_64
mesa-dri-drivers-19.0.7-1.fc30.x86_64

Comment 5 Jacek Pawlyta 2019-06-26 19:48:31 UTC
I am confirming this problem, ThinkPad T530 Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09) + NVidia NVS 5400M. Driver from NVidia works only on external monitor (no laptop screen), nouveau driver works only on one screen: laptop one or external.

Comment 6 ozeszty 2019-06-27 22:48:09 UTC
External monitor worked on Cinnamon spin, but only after I opened laptop's lid (enough for internal screen to blink) every time monitor was waking from power saving mode or after a mode change (start-up, user switch). Intel IvyBridge + AMD HD 7670M, HDMI. Xorg downgrade fixed this issue and redshift (not working also since 1.20.5-2).

Comment 7 Olivier Fourdan 2019-06-28 06:20:12 UTC
Looking at upstream changes between 1.20.4 and 1.20.5, I hardly see any changethat could explain sucha regression.

I suspect a downstream patch instead (as I mentioned a while ago in bug 1714981).

Comment 8 Olivier Fourdan 2019-06-28 06:23:25 UTC
Can you try with https://koji.fedoraproject.org/koji/taskinfo?taskID=35884171 once it's finished (scratch build) ?

Comment 9 Freddy Willemsen 2019-06-28 08:31:41 UTC
The scratch build seems to work fine on first glance. Hope some of the others can confirm.

Comment 10 Kamil Páral 2019-06-28 11:39:37 UTC
(In reply to Olivier Fourdan from comment #8)
> Can you try with
> https://koji.fedoraproject.org/koji/taskinfo?taskID=35884171 once it's
> finished (scratch build) ?

This behaves as expected and doesn't show the issues described in comment 4.

Comment 11 Freddy Willemsen 2019-06-28 12:11:01 UTC
Tested @home with a more exotic setup (2 external screens + laptop screen) and things seems to be just fine with the scratch build.

Comment 12 ozeszty 2019-06-28 13:08:34 UTC
External screen and redshift are working fine now.

Comment 13 Jacek Pawlyta 2019-06-28 15:33:17 UTC
For me the test build works fine.

Comment 14 Fedora Update System 2019-06-28 17:15:18 UTC
FEDORA-2019-84694484f4 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-84694484f4

Comment 15 Fedora Update System 2019-06-28 18:25:58 UTC
xorg-x11-server-1.20.5-3.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-84694484f4

Comment 16 Fedora Update System 2019-06-30 00:56:48 UTC
xorg-x11-server-1.20.5-3.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 17 cappellorosso 2019-07-09 10:11:38 UTC
I updated to xorg-x11-server-1.20.5 from the stable repository and I had to downgrade it since I had no video output from neither of my two monitors. I have this graphics:
1:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Hawaii PRO [Radeon R9 290/390] (rev 80)

Comment 18 Kamil Páral 2019-07-09 10:53:05 UTC
Cappellorosso, please report a new bug, attach the logs, make sure the bug is affected just by upgrading/downgrading xorg-x11 packages (and no other packages), and link it here. Thanks.

Comment 19 Olivier Fourdan 2019-07-09 11:17:43 UTC
Also, please be aware of bug 1726419 (fix in testing) and bug 1725499 which is causing corruption with AMD/ATI, fixes pending (scratch build in the relevant bug if you want to try)

Comment 20 cappellorosso 2019-07-09 14:17:18 UTC
I reported the bug (bug 1728279), I saw that it was dependent on xorg-x11-server-Xwayland in particular and that it was independent of the multimonitor setup.

Comment 21 Olivier Fourdan 2019-07-09 16:08:51 UTC
(In reply to cappellorosso from comment #20)
> I reported the bug (bug 1728279), I saw that it was dependent on
> xorg-x11-server-Xwayland in particular and that it was independent of the
> multimonitor setup.

No, in Wayland, Xwayland is not the display server and does not control the outputs, xrandr support in Xwayland is for backward compatibility and is read-only.

Reading bug 1728279, you're not using Wayland/Xwayland.

Comment 22 cappellorosso 2019-07-09 18:29:16 UTC
(In reply to Olivier Fourdan from comment #21)
> (In reply to cappellorosso from comment #20)
> > I reported the bug (bug 1728279), I saw that it was dependent on
> > xorg-x11-server-Xwayland in particular and that it was independent of the
> > multimonitor setup.
> 
> No, in Wayland, Xwayland is not the display server and does not control the
> outputs, xrandr support in Xwayland is for backward compatibility and is
> read-only.
> 
> Reading bug 1728279, you're not using Wayland/Xwayland.

Then I don't quite understand why it is the the only package which if I upgrade to causes the problem, and if I downgrade it the problem resolves.


Note You need to log in before you can comment on or make changes to this bug.