Bug 1723800 - [OVN] Updating a router's 'admin_state_up' returns OK but does not change the property
Summary: [OVN] Updating a router's 'admin_state_up' returns OK but does not change the...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-provider-ovn
Classification: oVirt
Component: provider
Version: 1.2.22
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ovirt-4.3.7
: 1.2.25
Assignee: Miguel Duarte Barroso
QA Contact: msheena
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-06-25 12:24 UTC by msheena
Modified: 2019-11-21 12:44 UTC (History)
7 users (show)

Fixed In Version: ovirt-provider-ovn-1.2.25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-21 12:44:46 UTC
oVirt Team: Network
sbonazzo: ovirt-4.3?


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 101200 0 master MERGED Allow routers to be disabled 2019-06-26 15:16:50 UTC

Description msheena 2019-06-25 12:24:01 UTC
Description of problem
=======================
Given I have an OVN router and it's 'admin_state_up' attribute is 'true',
When I try to update the attribute to 'false'
Then the provider returns 200 [OK] and in the response the attribute value remains 'true'. 

Version-Release number of selected component (if applicable)
============================================================
ovirt-provider-ovn-1.2.22-1.el7ev.noarch

How reproducible
================
100%

Steps to Reproduce:
1. Create a router with the following body:

{
    "router": {
    	"name": "router_1",
        "admin_state_up": true
    }
}
2. Update the 'admin_state_up' to be 'off' with the following body:

{
    "router": {
        "admin_state_up": false
    }
}

Actual results
==============
The provider returns 200 [OK] and the router entity where the property 'admin_state_up': true


Expected results
================
The provider returns 200 [OK] and the router entity where the property 'admin_state_up': false


Additional info
===============
If the router is created with 'admin_state_up': false it CAN be updated to be true, however once it is set to true it CANNOT be updated back to false.

Comment 1 msheena 2019-08-04 12:14:17 UTC
Verified with
=============
ovirt-engine-4.3.6-0.1.el7.noarch
ovirt-provider-ovn-1.2.25-1.el7ev.noarch

Comment 2 Dominik Holler 2019-09-04 06:49:07 UTC
Changing target milestone because bug 1744235 blocks 1.2.25 being part of ovirt-4.3.6.

Comment 6 Sandro Bonazzola 2019-11-21 12:44:46 UTC
This bugzilla is included in oVirt 4.3.7 release, published on November 21st 2019.

Since the problem described in this bug report should be
resolved in oVirt 4.3.7 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.