Bug 1723941 - Allow `oc adm release info` to output digest, name, or pull spec
Summary: Allow `oc adm release info` to output digest, name, or pull spec
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 4.1.z
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.1.z
Assignee: Maciej Szulik
QA Contact: zhou ying
URL:
Whiteboard: 4.1.4
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-06-25 19:39 UTC by Eric Paris
Modified: 2019-07-04 09:01 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-04 09:01:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:1635 None None None 2019-07-04 09:01:55 UTC

Description Eric Paris 2019-06-25 19:39:00 UTC
https://github.com/openshift/origin/pull/22977

Comment 2 zhou ying 2019-06-28 04:33:53 UTC
Confirmed with latest client 4.1.4-201906261555.git.0.c9e4f28.el7, works well:
[root@dhcp-140-138 ~]# oc adm release info registry.svc.ci.openshift.org/ocp/release:4.2.0-0.nightly-2019-06-27-204704   --commits  -o pullspec
quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:e5e539a01405f05cc8a94c04752bec886dfd2e91f421ef94d5b37ea8660747e1
quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:46d6adc979aead6908a57c8a1d771a498f93506c5bc9cd7bb8aceee041fc0242
...

[root@dhcp-140-138 ~]# oc adm release info registry.svc.ci.openshift.org/ocp/release:4.2.0-0.nightly-2019-06-27-204704   --commits  -o digest
sha256:e5e539a01405f05cc8a94c04752bec886dfd2e91f421ef94d5b37ea8660747e1
sha256:46d6adc979aead6908a57c8a1d771a498f93506c5bc9cd7bb8aceee041fc0242
...

[root@dhcp-140-138 ~]# oc adm release info registry.svc.ci.openshift.org/ocp/release:4.2.0-0.nightly-2019-06-27-204704   --commits  -o name
aws-machine-controllers
azure-machine-controllers
...

[root@dhcp-140-138 ~]# oc adm release info registry.svc.ci.openshift.org/ocp/release:4.2.0-0.nightly-2019-06-27-204704   --commits  -o json
{
  "image": "registry.svc.ci.openshift.org/ocp/release:4.2.0-0.nightly-2019-06-27-204704",
  "digest": "sha256:30f79c8afa66dc4cf73dae48d6881e34bc4fcb0fb2fb96e74efee0b1509a7f63",
....

Comment 6 errata-xmlrpc 2019-07-04 09:01:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:1635


Note You need to log in before you can comment on or make changes to this bug.