Bug 172402 - Add support for mod_restartd - remove Apache module packaging
Add support for mod_restartd - remove Apache module packaging
Status: CLOSED CURRENTRELEASE
Product: 389
Classification: Community
Component: Admin (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rich Megginson
Viktor Ashirov
:
Depends On:
Blocks: 152373 240316
  Show dependency treegraph
 
Reported: 2005-11-03 16:35 EST by Rich Megginson
Modified: 2015-12-07 11:57 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 11:57:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
List of files in fix (246 bytes, text/plain)
2005-11-03 16:35 EST, Rich Megginson
no flags Details
diffs for fix (10.72 KB, text/plain)
2005-11-03 16:36 EST, Rich Megginson
no flags Details

  None (edit)
Description Rich Megginson 2005-11-03 16:35:37 EST
mod_restartd is ready so it needs to be supported by Admin Server.
Since the Apache modules are all Apache licensed, they cannot be bundled and
distributed with our ds releases.  They will have to be downloaded and installed
separately.
Comment 1 Rich Megginson 2005-11-03 16:35:38 EST
Created attachment 120706 [details]
List of files in fix
Comment 2 Rich Megginson 2005-11-03 16:36:26 EST
Created attachment 120707 [details]
diffs for fix
Comment 3 Rich Megginson 2005-11-03 18:19:29 EST
Reviewed by: Noriko (Thanks!)
Files: https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=120706
Branch: HEAD
Fix Description: Add support for mod_restartd to the Admin Server 
httpd.conf and admserv.conf.  This just allows root to run the stop, 
start, and restart CGIs.  In addition to the regex in admserv.conf that 
restricts CGI access, the code in mod_restartd itself restricts CGIs to 
only those matching this pattern - all others get passed on to the 
regular CGI handling module.  Since our 3 Apache modules are all Apache 
licensed, they cannot be included in our rpm/tarball packaging for 
distribution.  They will have to be separate rpms/tarballs that the 
customer will have to download and install.
Platforms tested: RHEL4
Flag Day: no
Doc impact: no
QA impact: should be covered by regular nightly and manual testing
New Tests integrated into TET: none

Checking in adminserver/Makefile;
/cvs/dirsec/adminserver/Makefile,v  <--  Makefile
new revision: 1.16; previous revision: 1.15
done
Checking in adminserver/buildpaths.mk;
/cvs/dirsec/adminserver/buildpaths.mk,v  <--  buildpaths.mk
new revision: 1.4; previous revision: 1.3
done
Checking in adminserver/components.mk;
/cvs/dirsec/adminserver/components.mk,v  <--  components.mk
new revision: 1.39; previous revision: 1.38
done
Checking in adminserver/internal_buildpaths.mk;
/cvs/dirsec/adminserver/internal_buildpaths.mk,v  <--  internal_buildpaths.mk
new revision: 1.3; previous revision: 1.2
done
Checking in adminserver/nsconfig.mk;
/cvs/dirsec/adminserver/nsconfig.mk,v  <--  nsconfig.mk
new revision: 1.18; previous revision: 1.17
done
Checking in adminserver/admserv/pkgadmin.mk;
/cvs/dirsec/adminserver/admserv/pkgadmin.mk,v  <--  pkgadmin.mk
new revision: 1.29; previous revision: 1.28
done
Checking in adminserver/admserv/cfgstuff/admserv.conf;
/cvs/dirsec/adminserver/admserv/cfgstuff/admserv.conf,v  <--  admserv.conf
new revision: 1.9; previous revision: 1.8
done
Checking in adminserver/admserv/cfgstuff/httpd.conf;
/cvs/dirsec/adminserver/admserv/cfgstuff/httpd.conf,v  <--  httpd.conf
new revision: 1.6; previous revision: 1.5
done
Comment 4 Yi Zhang 2007-12-03 19:43:15 EST
Verification test: PASS
Test machine: neo.dsdev.sjc.redhat.com & cypher.dsdev.sjc.redhat.com

Test Steps:
1. install DS on neo.dsdev.sjc.redhat.com
2. install console on cypher.dsdev.sjc.redhat.com
3. launch console on cypher, remotely control DS on neo.dsdev.sjc.redhat.com
host by entering information of neo DS server, 
4. do "start/stop/restart DS server" to verify remote start/stop/restart
function (which are all relate to mod_restartd) works
Test result: passed

Note You need to log in before you can comment on or make changes to this bug.