Bug 17242 - rpm dumps core
rpm dumps core
Status: CLOSED DUPLICATE of bug 16684
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-04 20:02 EDT by Tethys
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-04 20:03:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tethys 2000-09-04 20:02:59 EDT
When trying to erase the fonttastic font server rpm shipped with CorelDRAW
9 beta 2,
rpm dumped core:

leto:~# rpm --erase fonttastic-glibc-2.1-2000.05.12.08.30-1
fonttastic-glibc-2.1-2000.05.12.08.30-1
Stopping the font server (if any)
Removing log file
(Ignore any subsequent errors about failing to remove files)
Removing links for init
Removing log file
cannot read packages named fonttastic-glibc-2.1 for uninstall
Segmentation fault (core dumped)

I doubt a stack trace will be of use without debugging symbols, but just in
case:

leto:~# gdb /bin/rpm core
GNU gdb 19991004
Copyright 1998 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you
are
welcome to change it and/or distribute copies of it under certain
conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux"...(no debugging symbols
found)...
Core was generated by `rpm --erase fonttastic-glibc-2.1-2000.05.12.08.30-1
fonttastic-glibc-2.1-2000.0'.
Program terminated with signal 11, Segmentation fault.
#0  0x80c4d04 in ?? ()
(gdb) bt
#0  0x80c4d04 in ?? ()
#1  0x80c6f13 in ?? ()
#2  0x809b18f in ?? ()
#3  0x80992dd in ?? ()
#4  0x809a0f8 in ?? ()
#5  0x809399f in ?? ()
#6  0x80785d3 in ?? ()
#7  0x807b826 in ?? ()
#8  0x804f713 in ?? ()
#9  0x80b43eb in ?? ()
(gdb) 

Note that I accidentally typed the name of the package to be removed twice. 
I don't know if this has a bearing on anything or not, but I tried removing
one
of the standard rpms that I don't use (joe-2.8-24), and it didn't dump
core,
even when repeated twice on the command line.
Comment 1 Jeff Johnson 2000-09-05 10:04:27 EDT

*** This bug has been marked as a duplicate of 16684 ***

Note You need to log in before you can comment on or make changes to this bug.