Bug 1724220 - Dry-run verification fails on task Stop iscsi.service
Summary: Dry-run verification fails on task Stop iscsi.service
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 15.0 (Stein)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: 15.0 (Stein)
Assignee: Cédric Jeanneret
QA Contact: Victor Voronkov
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-06-26 13:36 UTC by Victor Voronkov
Modified: 2019-09-26 10:52 UTC (History)
3 users (show)

Fixed In Version: openstack-tripleo-heat-templates-10.5.1-0.20190701110422.889d4d4.el8ost
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-21 11:23:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1834409 0 None None None 2019-06-27 05:26:32 UTC
OpenStack gerrit 667783 0 None None None 2019-06-27 05:26:32 UTC
Red Hat Product Errata RHEA-2019:2811 0 None None None 2019-09-21 11:23:51 UTC

Description Victor Voronkov 2019-06-26 13:36:30 UTC
Description of problem:
Running config-download playbook with --check (dry-run mode) fails
Topology - controller:3,compute:2,ceph:3

ansible log:
...
TASK [Stop iscsi.service] ******************************************************
fatal: [controller-0]: FAILED! => {"msg": "The conditional check 'iscsi_service_enabled_result.rc == 0' failed. The error was: error while evaluating conditional (iscsi_service_enabled_result.rc == 0): 'dict object' has no attribute 'rc'\n\nThe error appears to be in '/home/stack/config-download/Controller/host_prep_tasks.yaml': line 592, column 3, but may\nbe elsewhere in the file depending on the exact syntax problem.\n\nThe offending line appears to be:\n\n  register: iscsi_service_enabled_result\n- name: Stop iscsi.service\n  ^ here\n"}
fatal: [controller-1]: FAILED! => {"msg": "The conditional check 'iscsi_service_enabled_result.rc == 0' failed. The error was: error while evaluating conditional (iscsi_service_enabled_result.rc == 0): 'dict object' has no attribute 'rc'\n\nThe error appears to be in '/home/stack/config-download/Controller/host_prep_tasks.yaml': line 592, column 3, but may\nbe elsewhere in the file depending on the exact syntax problem.\n\nThe offending line appears to be:\n\n  register: iscsi_service_enabled_result\n- name: Stop iscsi.service\n  ^ here\n"}
fatal: [controller-2]: FAILED! => {"msg": "The conditional check 'iscsi_service_enabled_result.rc == 0' failed. The error was: error while evaluating conditional (iscsi_service_enabled_result.rc == 0): 'dict object' has no attribute 'rc'\n\nThe error appears to be in '/home/stack/config-download/Controller/host_prep_tasks.yaml': line 592, column 3, but may\nbe elsewhere in the file depending on the exact syntax problem.\n\nThe offending line appears to be:\n\n  register: iscsi_service_enabled_result\n- name: Stop iscsi.service\n  ^ here\n"}

Version-Release number of selected component (if applicable):


How reproducible:

By running these steps:

source /home/stack/stackrc

openstack overcloud config download --name overcloud --config-dir /home/stack/config-download

tripleo-ansible-inventory --ansible_ssh_user heat-admin --static-yaml-inventory inventory.yaml

ansible-playbook --check --become -i /home/stack/inventory.yaml /home/stack/config-download/deploy_steps_playbook.yaml

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Victor Voronkov 2019-07-04 08:47:55 UTC
Verified on compose RHOS_TRUNK-15.0-RHEL-8-20190701.n.0

Comment 9 errata-xmlrpc 2019-09-21 11:23:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.