Bug 172423 - "Keywords" validated as string, not localestring
"Keywords" validated as string, not localestring
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: desktop-file-utils (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-04 03:30 EST by Ville Skyttä
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-07 11:41:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Validate "Keywords" as localestring (939 bytes, patch)
2005-11-04 03:30 EST, Ville Skyttä
no flags Details | Diff

  None (edit)
Description Ville Skyttä 2005-11-04 03:30:06 EST
The value of the "Keywords" key in desktop entry files is validated as string,   
which is not too useful for localized keywords.   
   
I don't know of a specification that would define exactly what the "Keywords"   
key may contain, but the possibility of localizing the keywords would sound 
sane to me, and ASCII doesn't work for that purpose.   
   
A problem caused by this:   
https://www.redhat.com/archives/fedora-extras-list/2005-November/msg00197.html   
   
Suggested patch against f.d.o CVS attached.  Reported here because there's no   
component for desktop-file-utils in bugs.freedesktop.org.  (That's  
https://bugs.freedesktop.org/show_bug.cgi?id=4959)
Comment 1 Ville Skyttä 2005-11-04 03:30:07 EST
Created attachment 120717 [details]
Validate "Keywords" as localestring
Comment 2 Ray Strode [halfline] 2006-11-07 11:38:03 EST
So the only reference I can find to the use of Keywords, is here:

http://standards.freedesktop.org/desktop-entry-spec/latest/apb.html

It doesn't say what type it is, so if we're finding localestrings in the wild I
guess your patch makes sense.
Comment 3 Ray Strode [halfline] 2006-11-07 11:41:22 EST
committed.
Comment 4 Rex Dieter 2006-11-28 21:27:13 EST
This affects packaging of many kde applications.  
Can we expect a fixed desktop-file-utils to land in fedora soon?
Comment 5 Ray Strode [halfline] 2006-11-28 22:21:57 EST
Should be in tomorrow's rawhide.  Sorry for the delay; I thought I had already
pushed it to rawhide.

Note You need to log in before you can comment on or make changes to this bug.