Bug 1724250 - Make TLS 1.3 work in FIPS mode [rhel-8]
Summary: Make TLS 1.3 work in FIPS mode [rhel-8]
Keywords:
Status: NEW
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: nss
Version: 8.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: rc
: 8.0
Assignee: nss-nspr-maint
QA Contact: BaseOS QE Security Team
Mirek Jahoda
URL:
Whiteboard:
: 1723586 (view as bug list)
Depends On: 1809549
Blocks: 1724251 1739559 1765268 1723586
TreeView+ depends on / blocked
 
Reported: 2019-06-26 14:58 UTC by Hubert Kario
Modified: 2020-04-08 17:05 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Known Issue
Doc Text:
.TLS 1.3 does not work in NSS in FIPS mode TLS 1.3 is not supported on systems working in FIPS mode. As a result, connections that require TLS 1.3 for interoperability do not function on a system working in FIPS mode. To enable the connections, disable the system's FIPS mode or enable support for TLS 1.2 in the peer.
Clone Of:
: 1724251 (view as bug list)
Environment:
Last Closed:
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Mozilla Foundation 1561637 P2 RESOLVED TLS 1.3 does not work in FIPS mode 2020-07-02 09:31:08 UTC
Red Hat Bugzilla 1709796 None None None 2019-12-05 00:47:18 UTC

Internal Links: 1709796

Description Hubert Kario 2019-06-26 14:58:18 UTC
Description of problem:
Because of compliance reasons (see bug 1709796) TLS 1.3 is unavailable in FIPS mode.

fix this issue and allow use of TLS 1.3 in FIPS mode

Comment 8 Hubert Kario 2020-03-03 16:08:29 UTC
*** Bug 1723586 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.