Bug 1724283 - 10.4.6 & 10.4.7 module crashes when the replication is wrongly configured ("wsrep_on=1" is used with default unchanged configuration) (= mariadb-galera is installed)
Summary: 10.4.6 & 10.4.7 module crashes when the replication is wrongly configured ("w...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora Modules
Classification: Fedora
Component: mariadb
Version: unspecified
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Michal Schorm
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-06-26 16:22 UTC by Michal Schorm
Modified: 2020-01-19 20:43 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-19 20:43:56 UTC


Attachments (Terms of Use)

Description Michal Schorm 2019-06-26 16:22:52 UTC
The MariaDB 10.4.6 module crashes with a coredump, when trying to use replication.


When "mariadb-galera" package is installed, it will add a "/etc/my.cnf.d/galera.cnf" configuration file with option "wsrep_on=1".

In that case, the start of the mysqld daemon (e.g. by "systemctl start mariadb") will fail with a coredump.

--

Workarounds:
1) do not install "mariadb-galera" package
2) set "wsrep_on=0" in your cofiguration, do not use replication.

-----------------------------------------

# coredumpctl -1 dump
           PID: 26621 (mysqld)
           UID: 27 (mysql)
           GID: 27 (mysql)
        Signal: 11 (SEGV)
     Timestamp: Wed 2019-06-26 12:19:33 EDT (2min 34s ago)
  Command Line: /usr/libexec/mysqld --basedir=/usr
    Executable: /usr/libexec/mysqld
 Control Group: /system.slice/mariadb.service
          Unit: mariadb.service
         Slice: system.slice
       Boot ID: d5dbb8d483244fb7b56054e42b85223b
    Machine ID: 78722d4a61d145e9af550b0781bbf998
      Hostname: host-10-0-137-33
       Storage: /var/lib/systemd/coredump/core.mysqld.27.d5dbb8d483244fb7b56054e42b85223b.26621.1561565973000000.lz4
       Message: Process 26621 (mysqld) of user 27 dumped core.
                
                Stack trace of thread 26621:
                #0  0x00007f88acc1591b kill (libc.so.6)
                #1  0x000055afae22713a handle_fatal_signal (mysqld)
                #2  0x00007f88ad102e30 __restore_rt (libpthread.so.0)
                #3  0x000055afadf3dd5c unireg_abort (mysqld)
                #4  0x000055afadf45be2 _Z11mysqld_mainiPPc (mysqld)
                #5  0x00007f88acc00193 __libc_start_main (libc.so.6)
                #6  0x000055afadf38ace _start (mysqld)

Comment 1 Michal Schorm 2019-09-06 11:47:33 UTC
Reported upstream as:
https://jira.mariadb.org/browse/MDEV-20505

--

It seems that, when properly configured, the issue is not triggered.

Comment 2 Michal Schorm 2020-01-19 20:43:56 UTC
Rawhide just recieved the 10.4.11 release.

The issue is fixed there by setting "wsrep_on=0" by default, so user must enable it before using it.


Note You need to log in before you can comment on or make changes to this bug.