Bug 172444 - fullscreen doesn't work properly on a rotated screen
fullscreen doesn't work properly on a rotated screen
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-04 11:07 EST by Radek Bíba
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-17 19:41:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Radek Bíba 2005-11-04 11:07:19 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc3 Firefox/1.0.7

Description of problem:
With xorg set up to use rotated screen it's actually impossible to run any
fulscreen applications that expect normal (landscape) settings. Their 'sandbox' is
wider than the screen and below it there's a part of the screen that was below
before the application went fullscreen.

Version-Release number of selected component (if applicable):
xorg-x11-6.8.2-1.FC3.45.2

How reproducible:
Always

Steps to Reproduce:
1. set up rotated screen
(e.g. 'Option "Rotate" "CCW"' in Device and InputDevice sections)
2. run X, open a fullscreen application, e.g. tuxracer (FC < 4)
  

Actual Results:  not really fullscreen, larger than actual screen (mouse can "scroll" horizontally
to see the rest, at least), "garbage" below

Expected Results:  well, I know, fullscreen apps often expect 3:4 ratio, wider than higher; what
I expect on on 4:3 screen is that the application fits horizontally, is centered
vertically and there is a dark above and below, like with wide-angle movies on
common screens.

Additional info:
Comment 1 Mike A. Harris 2006-01-17 19:41:19 EST
Fullscreen apps such as video games, generally expect a 4:3 aspect ratio
(not 3:4).  If you have rotated your screen, then the software you are
running needs to be capable of running in the dimensions of the rotated
screen.  If it does not work correctly, then that is a limitation in
the software you are running, and you will need to file a bug report
to the authors of that software, or alternatively unrotate the screen
to use the particular software.

In addition however, the rotation options that are available in certain
drivers have inherent limitations, and as such, may not be suitable for
all purposes.  Please use the xorg@lists.freedesktop.org mailing list to
discuss any problems you may experience regarding driver specific rotation
options.  If a bug in a driver can be proven to exist when in rotation
mode, then a bug should be filed in X.Org bugzilla to alert the driver
maintainer, at http://bugs.freedesktop.org in the "xorg" component.

Since what you describe sounds like a limitation in the tuxracer game, and
not a bug in X or the driver, I'm closing the bug as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.