Bug 172445 - samba is unable to share folders read/write
samba is unable to share folders read/write
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
4
All Linux
medium Severity high
: ---
: ---
Assigned To: Simo Sorce
David Lawrence
:
: 172451 172452 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-04 11:10 EST by drago01
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-14 17:42:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
my smb.conf (10.93 KB, text/plain)
2005-11-04 11:11 EST, drago01
no flags Details

  None (edit)
Description drago01 2005-11-04 11:10:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); de-DE; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
When I create a writeable samba share, I still cannot write to it (permission denieded). I have also tryed with selinux disabled but it still was broken.
will attach smb.conf after submitting this

Version-Release number of selected component (if applicable):
samba-3.0.14a-2

How reproducible:
Always

Steps to Reproduce:
1. share a folder read/write
2. mount it
3. try to write to it
  

Actual Results:  can't write (permission denieded)

Expected Results:  should be able to write to (as I allowed it)

Additional info:

no errors in /var/log/audit/audit.log (have also tryed with setenforce 0)
Comment 1 drago01 2005-11-04 11:11:37 EST
Created attachment 120729 [details]
my smb.conf
Comment 2 drago01 2005-11-11 09:59:09 EST
any idea what could be causing this?
is there any way how I could provide more info?
please help this bug makes samba unuseable for me.
Comment 3 drago01 2005-11-13 06:31:48 EST
after playing with the config file and google I have found out that it was a
config issue not a bug.
the guest user had no permissions to write to this dir.
Comment 4 Ashley Wise 2005-11-14 08:19:01 EST
(In reply to comment #3)
> after playing with the config file and google I have found out that it was a
> config issue not a bug.
> the guest user had no permissions to write to this dir.

Whoa hey, please don't close it without explaining exactly how to fix it! And 
I'm not convinced it's not a bug yet. I tried creating shared folders all over 
the file system, and mapping samba users to every user on the system, and I 
mucked with all the smb.conf settings I read about on the internet, and I 
could never get write-permissions to work.

{which by the way, is probably another bug, that whenever I would open the 
samba server GUI control panel, it would clobber any manual changes I'd made 
to the .conf file).

I have samba users mapped to my own account, which definitely does have write 
permissions (and regardless, I'd setup the folders and the whole directory 
tree up to the folder to have 777 permissions, so anyone should have had write 
access). And still it always fails to have write permissions.

I tried everything I found on google and never got it to work. So please 
either post a step-by-step explaination of how to get it to work, or please re-
open this bug.

Also, this is all in share-mode samba. See my bug#172451 about how user-mode 
doesn't work:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=172451

Thanks.
Comment 5 drago01 2005-11-14 10:35:16 EST
for me it works when the samba guest user has write permissions to the share.
ex:
/home/xx which is owned by xx. If I set the guest to xx or root it works.
Comment 6 Christian Iseli 2007-01-19 19:24:35 EST
This report targets the FC3 or FC4 products, which have now been EOL'd.

Could you please check that it still applies to a current Fedora release, and
either update the target product or close it ?

Thanks.
Comment 7 drago01 2007-01-20 02:36:54 EST
seems work fine with samba-3.0.23c-2 on fc6
Comment 8 Simo Sorce 2007-03-14 17:42:42 EDT
closing this, reopen if there is a real reproducible bug.
Comment 9 Simo Sorce 2007-03-14 17:49:07 EDT
*** Bug 172451 has been marked as a duplicate of this bug. ***
Comment 10 Simo Sorce 2007-03-14 17:50:31 EDT
*** Bug 172452 has been marked as a duplicate of this bug. ***
Comment 11 Simo Sorce 2007-03-14 17:51:45 EDT
Sorry these are not bugs but configuration problems, probably due to an
incorrect use of the guest user.

Note You need to log in before you can comment on or make changes to this bug.