Bug 172447 - up2date hangs with initRepo errors
up2date hangs with initRepo errors
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bret McMillan
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-04 11:28 EST by Ashley Wise
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-05 11:32:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Message box error list from up2date (7.37 KB, text/plain)
2005-11-04 12:44 EST, Ashley Wise
no flags Details

  None (edit)
Description Ashley Wise 2005-11-04 11:28:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)

Description of problem:
I run the up2date GUI (launched from a console).

The first time I did this, it got about so far and then complained that it failed to install the kde-i18n-somelanguage. I unchecked it from the list and tried again. Then it got pretty far, and then started outputting these:
initRepo
bytes=440-####
initRepo
initRepo
initRepo
bytes=440-####

And eventually it hung. I had to force-quit it.

Then I killed it and launched it again, and it did the same thing (hung after tons of initRepo messages).

Then I tried it again, and now all the packages show up as 0kb (the first time I did it, they had valid sizes).

Version-Release number of selected component (if applicable):
up2date-4.4.23-4

How reproducible:
Always

Steps to Reproduce:
1. Launch "up2date"
2. Select all packages
3. Run
  

Actual Results:  Install failures and initRepo hangs

Expected Results:  Installed all the packages.

Additional info:
Comment 1 Ashley Wise 2005-11-04 12:44:21 EST
Created attachment 120735 [details]
Message box error list from up2date

I ran up2date yet again, and this time it reproduced the error with the
kdb-i18n-polish conflicts. I've copied the message box text that contains all
the conflicts it detected which halted the update.

Another "feature" to note is that the message box was so large (holding all
that text), that the title-bar was above the screen and the OK button below the
screen, so I couldn't actually do anything with the window (except
right-clicking on the frame to select the manual Move command to move the
window up so that the OK button would come into view). I don't think the
messagebox code needs to be changed (like adding scroll-bars if the content is
large), but rather maybe the up2date program should output these messages to a
logfile or console or special window with a scrollbar or something that can
handle that much text instead.
Comment 2 John Thacker 2006-10-29 15:31:54 EST
up2date was replaced by pirut and put (package pirut) as of FC5.  Only FC5 and
FC6 are currently fully supported; FC3 and FC4 are supported for security fixes
only.  If this bug occurs in FC3 or FC4 and is a security bug, please change the
product to Fedora Extras and the version to match.  If you can verify that the
bug exists in RHEL as well, please change the product and version appropriately.

The codebase for pirut and pup is quite different, but if a similar bug exists
in pirut and pup in FC5 or FC6, please change the product to pirut and the
version appropriately and update the bug report.

We apologize that the bug was not fixed before now.  The status will be changed
to NEEDINFO, and if the bug is not updated with evidence that it is a security
bug or a bug that affects RHEL, it will be closed.
Comment 3 John Thacker 2006-11-05 11:32:57 EST
Closing per previous message.

Note You need to log in before you can comment on or make changes to this bug.