Bug 172448 - vncpasswd returns a glibc error, with stack trace
vncpasswd returns a glibc error, with stack trace
Status: CLOSED DUPLICATE of bug 160471
Product: Fedora
Classification: Fedora
Component: vnc (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-04 11:48 EST by Jasper O. Hartline
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-07 06:04:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vncpasswd terminal output (2.02 KB, text/plain)
2005-11-04 12:22 EST, Jasper O. Hartline
no flags Details

  None (edit)
Description Jasper O. Hartline 2005-11-04 11:48:42 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923 Fedora/1.7.12-1.5.1

Description of problem:
Upon running vncpasswd, and entering the correct passwords 3 times over, vncpasswd refuses to change the password. glibc error with stack trace is displayed.
Here is a small excerpt, the full output will be as an attachment:

Password:
Verify:
Passwords don't match - try again
*** glibc detected *** vncpasswd: free(): invalid next size (fast): 0x09711130 ***
======= Backtrace: =========

Version-Release number of selected component (if applicable):
vnc-server-4.1.1-10.1

How reproducible:
Always

Steps to Reproduce:
1. Run: vncpasswd
2. Type password twice
3. Recieve a backtrace stacktrace
  

Actual Results:  vncpasswd failed to change a password for the vncserver application in vnc-server-4.1.1-10.1

Expected Results:  Password should have changed, and been immediately usable, as far as I know.

Additional info:

Could be something on my machine.
I am not absolutely certain, and with the conflicting reports I sometimes get from bugzilla responses, I am still unsure. I however do not think my glibc packages are broken, if they were I think I'd be seeing many more problems.
Just a guess.
Comment 1 Jasper O. Hartline 2005-11-04 12:22:39 EST
Created attachment 120734 [details]
vncpasswd terminal output

vncpasswd backtrace stacktrace glibc terminal output
Comment 2 Tim Waugh 2005-11-07 06:04:46 EST
Sounds like a duplicate of bug #160471.  The work-around is to limit your
password to 8 characters. (Characters beyond that are ignored anyway.)

*** This bug has been marked as a duplicate of 160471 ***

Note You need to log in before you can comment on or make changes to this bug.