Bug 172455 - X eventually crashes (screen corrupted) when running firefox
X eventually crashes (screen corrupted) when running firefox
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: xorg-x11 (Show other bugs)
4.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-04 14:45 EST by david
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-20 08:04:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description david 2005-11-04 14:45:19 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.12) Gecko/20050921 Red Hat/1.0.7-1.4.1 Firefox/1.0.7

Description of problem:
X crashes if I use the firefox web browser long enough when using the standard nvidia (nv) display driver shipped with RHEL4. 

My system has an nvidia Geforce 6200 video card. If I load the linux driver distributed by nvidia instead of the one shipped with RHEL4 (nv) then the problem goes away - using firefox does not result in X crashing. The nvidia driver contains the following documentation describing a possible X crash situation on the x86_64 architecture due to a kernel issue:

-- from the nvidia linux driver documentation --

The X86-64 platform (AMD64/EM64T) and 2.6 kernels

    Many 2.4 and 2.6 x86_64 kernels have an accounting issue in their
    implementation of the change_page_attr kernel interface. Early 2.6
    kernels include a check that triggers a BUG() when this situation is
    encountered (triggering a BUG() results in the current application
    being killed by the kernel; this application would be your opengl
    application or potentially the X Server). The accounting issue has
    been resolved in the 2.6.11 kernel.

    We have added checks to recognize that the NVIDIA kernel module is
    being compiled for the x86-64 platform on a kernel between 2.6.0 and
    2.6.11. In this case, we will disable usage of the change_page_attr
    kernel interface. This will avoid the accounting issue but leaves the
    system in danger of cache aliasing (see entry on Cache Aliasing for
    more information about cache aliasing). Note that this
    change_page_attr accounting issue and BUG() can be triggered by other
    kernel subsystems that rely on this interface.

    If you are using a 2.6 x86_64 kernel, it is recommended that you
    upgrade to a 2.6.11 or later kernel.

----------

I could find no reference to this issue in bugzilla so I decided to add a bug report against RHEL4 since it seems likely that this problem was causing my X server to crash when running the stock nv driver since changing to the driver from nvidia seems to have solved the problem for the moment.  

The RHEL4 kernel is based on 2.6.9 - has the fix for this problem been back ported to the RHEL4 kernel from the 2.6.11+ kernel?



Version-Release number of selected component (if applicable):
kernel-2.6.9-22.0.1.EL 

How reproducible:
Always

Steps to Reproduce:
1. Run firefox for a sufficiently long time looking at complex web sites. 
2. X or screen manager eventually dies - screen corrupted - logout or cntl-alt-backspace to reset.
3.
  

Actual Results:  The screen shows alot of corruption - various artifacts - windows can still be accessed but screen is not refreshed properly if at all. 

Expected Results:  System should have continued to display correctly. 

Additional info:
Comment 4 Mike A. Harris 2005-12-07 02:37:06 EST
This problem is believed to be a general bug in the open source "nv" driver's
2D acceleration code supplied by Nvidia to the X.Org project.

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=geforce-6x00 is the
bug filed for this issue for Fedora Core, which may contain information
useful in diagnosing your problem to determine if it is the same issue.

Try using the option "XaaNoScreenToScreenCopy" in the Device section of your
xorg.conf file and see if stability improves.  If you still have a problem
with stability, try adding the following options one at a time and testing
between each addition:

Option "XaaNoImageWriteRect"
Option "XaaNoOffscreenPixmaps"
Option "XaaNoPixmapCache"

Please try these options and report back if it changes anything.  Please
note that these options will degrade performance of the video driver
to some degree.

Thanks in advance.




Extra information:
The problem you are experiencing with the "nv" driver shipped with the OS
described in the initial comment, is an issue that is unrelated to the
problem described in the documentation for the proprietary nvidia driver
with regards to the kernel.  The 2 drivers share no common source code,
and the open source driver does not have a kernel module associated with
it.  The problem described in Nvidia's documentation is unique to their
proprietary driver.



Comment 5 Mike A. Harris 2006-01-20 08:04:15 EST
This report contains insufficient information to fully diagnose and conclude
what the problem may be.

At this time we are unable to diagnose the issue further without additional
feedback from the reporter in response to the suggestions provided above in
comment #4.

If this problem still occurs, please file a support web ticket at Red Hat
support services at http://www.redhat.com/support or by calling 1-888-RED-HAT1
depending on your support contract arrangements, and a Red Hat support
representative will assist in diagnosing the problem further.


Note You need to log in before you can comment on or make changes to this bug.