Bug 1724718 - 3.11.123 prerequisites playbook fails because openshift_use_crio is not defined
Summary: 3.11.123 prerequisites playbook fails because openshift_use_crio is not defined
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.11.z
Assignee: Russell Teague
QA Contact: Weihua Meng
URL:
Whiteboard:
Depends On:
Blocks: 1710020
TreeView+ depends on / blocked
 
Reported: 2019-06-27 15:44 UTC by Candace Sheremeta
Modified: 2019-07-23 19:56 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: In some cases, defaults were not loaded for hosts during sanity checks. Consequence: Sanity checks would fail. Fix: Added a step to run openshift_facts to load all defaults. Result: Defaults are loaded for all hosts and sanity checks run successfully.
Clone Of:
Environment:
Last Closed: 2019-07-23 19:56:39 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:1753 None None None 2019-07-23 19:56:43 UTC

Description Candace Sheremeta 2019-06-27 15:44:47 UTC
Description of problem: For some reason, 3.11.123 prerequisites playbook does not seem to be setting the openshift_use_crio variable to the default of false when it is not explicitly defined in the inventory file, leading to these errors:

~~~
TASK [Verify SELinux is enabled] ***********************************************
task path: /usr/share/ansible/openshift-ansible/playbooks/init/sanity_checks.yml:42
fatal: [openshift.example.com]: FAILED! => {"msg": "The conditional check 'not openshift_use_crio | bool' failed. The error was: error while evaluating conditional (not openshift_use_crio | bool): 'openshift_use_crio' is undefined\n\nThe error appears to have been in '/usr/share/ansible/openshift-ansible/playbooks/init/sanity_checks.yml': line 42, column 5, but may\nbe elsewhere in the file depending on the exact syntax problem.\n\nThe offending line appears to be:\n\n  # https://docs.openshift.com/container-platform/3.11/install/prerequisites.html#prereq-selinux\n  - name: Verify SELinux is enabled\n    ^ here\n"}
~~~


Version-Release number of the following components:
rpm -q openshift-ansible

openshift-ansible-3.11.123-1.git.0.db681ba.el7.noarch


rpm -q ansible

ansible-2.6.17-1.el7ae.noarch


How reproducible: I was not able to reproduce this after some simple testing, but I did check through the plays/tasks being run in my ansible logs vs customer ansible logs and did not see any significant difference between the plays/tasks run and the output between the two logs.

Additional info:

Will attach logs as private attachments

Comment 5 Russell Teague 2019-06-27 17:32:38 UTC
I was not able to reproduce this issue however a PR has been opened to ensure all defaults are loaded for all hosts during sanity checks.
https://github.com/openshift/openshift-ansible/pull/11724

Comment 7 Weihua Meng 2019-06-28 09:00:33 UTC
I can reproduce this.

Fixed in openshift-ansible-3.11.124

Comment 8 Weihua Meng 2019-06-28 09:13:36 UTC
Hi, Candace

Although this bug is fixed, install is likely to fail due to not meet selinux settings

this is from master sosreport
SELINUX=permissive

https://docs.openshift.com/container-platform/3.11/install/prerequisites.html#prereq-selinux

Comment 9 Candace Sheremeta 2019-06-28 13:18:46 UTC
Hey Weihua,

Excellent catch, thank you so much!

Comment 11 Weihua Meng 2019-07-10 14:05:45 UTC
Verified.

Comment 13 errata-xmlrpc 2019-07-23 19:56:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:1753


Note You need to log in before you can comment on or make changes to this bug.