Bug 1724719 - OSP15 overcloud nodes registration to Satellite 6.5 fails while running subscription-manager list --available with HTTP error (500 - Internal Server Error): Required lock is already taken by other running tasks
Summary: OSP15 overcloud nodes registration to Satellite 6.5 fails while running subsc...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: ansible-role-redhat-subscription
Version: 15.0 (Stein)
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: rc
: 15.0 (Stein)
Assignee: Emilien Macchi
QA Contact: Sasha Smolyak
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-06-27 15:46 UTC by Lon Hohberger
Modified: 2019-09-26 10:53 UTC (History)
9 users (show)

Fixed In Version: ansible-role-redhat-subscription-1.0.4-0.20190701140422.fceb51c.el8ost
Doc Type: No Doc Update
Doc Text:
Clone Of: 1715958
Environment:
Last Closed: 2019-09-21 11:23:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 667440 0 None None None 2019-06-27 15:48:10 UTC
Red Hat Product Errata RHEA-2019:2811 0 None None None 2019-09-21 11:24:14 UTC

Description Lon Hohberger 2019-06-27 15:46:57 UTC
+++ This bug was initially created as a clone of Bug #1715958 +++

Description of problem:

OSP15 overcloud nodes registration to Satellite 6.5 fails while running subscription-manager list --available with HTTP error (500 - Internal Server Error): Required lock is already taken by other running tasks

Version-Release number of selected component (if applicable):
ansible-role-redhat-subscription-1.0.3-0.20190423160356.50120ad.el8ost.noarch
ansible-2.8.0-1.el8ae.noarch

How reproducible:
100%

Steps to Reproduce:

1. Deploy overcloud with nodes registered to Satellite 6.5

Actual results:

Deployment fails because Satellite returns:

 HTTP error (500 - Internal Server Error): Required lock is already taken by other running tasks.\nPlease inspect their state, fix their errors and resume them.\n\nRequired lock: update\nConflicts with tasks:\n- https://sealusa10.mobius.lab.eng.rdu2.redhat.com/foreman_tasks/tasks/7fac8bef-6b39-4482-bc5c-25e924c25c32" 

when the node is running 'subscription-manager list --available'

Checking the task on the Satellite server we can see it takes 4 seconds to finish so we should probably implement a retry mechanism to allow long running task to complete on Satellite side. 

Expected results:

Overcloud nodes registration completes successfully.

Additional info:

Attaching /var/lib/mistral/overcloud/ansible.log

Comment 8 errata-xmlrpc 2019-09-21 11:23:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.