Bug 172492 - tetex-font-kerkis - package scripts are using wrong config file
Summary: tetex-font-kerkis - package scripts are using wrong config file
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: tetex-font-kerkis   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Sarantis Paskalis
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On: 172507
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-11-05 07:13 UTC by Michal Jaegermann
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-06 17:30:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michal Jaegermann 2005-11-05 07:13:41 UTC
Description of problem:

%pre and %post scripts need to make sure that updmap.cfg is the one
which is listed by 'texconfig-sys conf' on the original installation
and which is marked as %config by rpm.  Otherwise they create a new,
independent, updmap.cfg in some directory which depends on changeable
ordering in $TEXFONTMAPS variable.

In other words a postinstall scriptlet should be like this:

/usr/bin/texhash
if [ "$1" = "1" ]; then
  /usr/bin/updmap-sys  --cnffile /usr/share/texmf/web2c/updmap.cfg \
     --quiet --nohash --enable Map=kerkis.map
fi

and postuninstall one

if [ "$1" = "0" ]; then
  /usr/bin/updmap-sys --cnffile /usr/share/texmf/web2c/updmap.cfg \
     --quiet --nohash --disable kerkis.map
fi
/usr/bin/texhash

Version-Release number of selected component (if applicable):
tetex-font-kerkis-2.0-9.fc5 but this equally applies to
tetex-font-kerkis-2.0-9.fc4

How reproducible:
always and creating updmap.sys is messing up a system as the first found
updmap.sys is used so cleaning that up requires not only removing such
extra configuration files and rerunnig, with a correct configuration
file, updmap-sys for all extra packages with configuration written in
a "wrong" places.  Nasty and I do not see a good way to make that automatic.

Comment 1 Sarantis Paskalis 2005-11-05 15:38:01 UTC
I believe this is a bug in tetex.  texconfig-sys conf specifies
TEXMFSYSCONFIG=/usr/share/texmf-config, and that is where updmap.cfg should be
located.  The marking of /usr/share/texmf/web2c/updmap.cfg as config is an rpm
specific thing which should also be changed.

I opened a bug against tetex (bug #172507) and will wait to see the reaction
before closing this.


Comment 2 Sarantis Paskalis 2005-11-06 17:30:36 UTC
Given the discussion in bug #172507, it looks like an interim solution could be
to use a run-time configuration file.  It seems also safe both for systems which
do and do not have tetex-font-cm-lgc installed.

I will update the spec file as suggested in comment #2 of bug #172491.

Thanks


Note You need to log in before you can comment on or make changes to this bug.