Bug 1725006 - The 4.1 Cluster Console does not allow the creation of Routes with multiple service endpoints, which was one of the features of the 3.x dev UI
Summary: The 4.1 Cluster Console does not allow the creation of Routes with multiple s...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.3.0
Assignee: Joe Caiani
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-06-28 09:00 UTC by Ian Lawson
Modified: 2020-01-23 11:04 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Because of the changes between 3.x and 4.x there were some features that were not in sync. Consequence: The 4.1 Cluster Console does not allow the creation of Routes with multiple service endpoints in the UI, which was one of the features of the 3.x dev UI. In 4.x this feature is available by editing the yaml of a route, however, it is missing in the GUI Route form. Fix: Add the ability in the GUI form to add/remove up to 3 alternate service endpoints. Result: The configuration of multiple service endpoints on a route is now in sync with the 3.11 version of openshift via both yaml and forms.
Clone Of:
Environment:
Last Closed: 2020-01-23 11:04:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 2430 'None' 'closed' 'Bug 1725006: Add multiple service endpoints to create route' 2019-11-26 03:01:44 UTC
Red Hat Product Errata RHBA-2020:0062 None None None 2020-01-23 11:04:40 UTC

Description Ian Lawson 2019-06-28 09:00:47 UTC
Description of problem:

Creation of a new Route within a namespace that has multiple Services does not provide a mechanism for splitting the traffic across multiple Service endpoints with a weighting as was provided graphically in the 3.x console. Whilst this still can be achieved by handcrafting YAML it was a feature that customers liked, especially for Canary deployments of applications


Version-Release number of selected component (if applicable):

OCP4.1, K8S v1.13.4+838b4fa

How reproducible:

Always, option is missing from the Create Route dialog

Steps to Reproduce:
1. Add two applications to a namespace (i.e. nodetest1, nodetest2)
2. Ensure that the nodetest1 and nodetest2 Service exist by going to Networking/Services on the OCP4.1 management console
3. Select Networking/Routes, Create Route

Actual results:

UI components allow for the creation of a Route with a single Service endpoint and no option to add an additional one with a network weighting for splitting traffic

Expected results:

OCP3.11 provides this graphical functionality. In the absence of the 4.2 Pipeline UI which I assume won't bring this back the 4.1 UI does not - you can handcraft YAML but that is not intuitive for existing customers of 3.x that use this feature


Additional info:

Comment 2 Yanping Zhang 2019-10-22 03:24:32 UTC
4.3.0-0.nightly-2019-10-20-140322
Checked on OCP 4.3 with above payload version, now creating route with multiple services from form is available on console.
The bug is fixed.

Comment 4 errata-xmlrpc 2020-01-23 11:04:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.