This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 172524 - tetex packaging and configuration can use some "consistency adjustments"
tetex packaging and configuration can use some "consistency adjustments"
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: tetex (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
David Lawrence
:
: 172507 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-05 19:44 EST by Michal Jaegermann
Modified: 2013-07-02 19:10 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-09 08:50:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2005-11-05 19:44:15 EST
Description of problem:

teTeX-3.0 added some flexibility to the whole system and rpm packages likely
should be adjusted accordingly.  In particular in an output of
'teconfig conf', and in texmf.cnf, one can find

TEXMFDIST=/usr/share/texmf-dist
TEXMFLOCAL=/usr/local/share/texmf
TEXMFSYSVAR=/usr/share/texmf-var
TEXMFSYSCONFIG=/usr/share/texmf-config

These directories possibly should be created as a part of standard packages
although the case is quite weak for TEXMFLOCAL and very strong for the
last two as these directories will be created by various configuration
utilities anyway even if you will work hard to avoid putting anything there.

Moreover files which one can find under "== active config files ==".
at least those which currently reside in /usr/share/texmf/web2c/, should
be moved to /usr/share/texmf-config/web2c/.  Most likely other config
files should be moved to corresponding locations under /usr/share/texmf-config/.
In principle the whole /usr/share/texmf/ tree can be mounted from read-only
media and it should be treated as such.  Configuration files anyway will be
searched along the whole TEXCONFIG "path" which is quite extensive.

NOTE: various package scripts which may use fmtutil-sys and/or updmap-sys
should not make any assumptions on location of configuration files but
they should check, via an ouput of 'texconfig-sys conf', where various
files in the current use are *really* located and use options as --cnffile
with results of the preceding check.  Hardwiring any locations in such
scripts is not a good practice.  A note to that efect should find its way
to a package documentation (in %{_docdir}/tetex-<version>/ ?).

Version-Release number of selected component (if applicable):
tetex-3.0-8 and earlier
Comment 1 Sarantis Paskalis 2005-11-06 12:20:27 EST
*** Bug 172507 has been marked as a duplicate of this bug. ***
Comment 2 Michal Jaegermann 2005-11-25 11:34:04 EST
'rpm -q --changelog tetex-3.0-10' now says, amount other things,
"- use @texmf@-var, @texmf@-config trees" but 'rpm -qf /usr/share/texmf-*'
gives:

file /usr/share/texmf-config is not owned by any package
file /usr/share/texmf-var is not owned by any package

As a matter of fact none of subdirectories of /usr/share/texmf-var is owned by
any package.  Some, although not all, _files_ in those directory tries indeed
belong to tetex-3.0-10.  Is this how it was intended?  Maybe some %ghost
directives should be used?

It seems that populating and using a subtree of /usr/share/texmf-config
right from the start could be a good move.
Comment 3 Jindrich Novy 2005-11-25 14:24:56 EST
This is caused by changes I made by accident in previous build which are now
reverted, where TEXMFCONFIG and TEXMFVAR was poining to $TEXMFMAIN. I didn't
commit any fix related to this bug. Note it's still in the NEW state. I need a
bit more time to fix it as I'm rather busy at the moment. I agree with your
proposed solution though.
Comment 4 Jindrich Novy 2007-12-09 08:50:30 EST
teTeX is now obsoleted by TeXLive in rawhide and removed. If you are sure the
problem still applies also for TeXLive, please file a bug against following
rawhide components:

texlive       - if you found bug in binary TeXLive utilities
texlive-texmf - if find anything related to fonts/styles, noarch part
texlive-texmf-errata - if you need to update font/style set.

Note You need to log in before you can comment on or make changes to this bug.