Bug 172532 - installer crashes on kickstart install
installer crashes on kickstart install
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-06 07:26 EST by Russell Coker
Modified: 2008-03-14 19:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-14 19:41:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda dump log (136.17 KB, text/plain)
2005-11-06 07:27 EST, Russell Coker
no flags Details

  None (edit)
Description Russell Coker 2005-11-06 07:26:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.4; Linux) KHTML/3.4.92 (like Gecko)

Description of problem:
I was doing kickstart installation of fc5-pre-test1, I used the same   
configuration on two machines.  One machine worked correctly and the other   
failed.  Both machines were identical IBM desktop machines purchased at the   
same time.   
   
The machine that worked had 384M of RAM and the one that failed had 256M of   
RAM, but I don't believe that this is the problem (I installed some HP   
machines with 256M using the same configuration).   
   
The issue seems to be that the failing machine had a prior LVM install with an   
active LVM snapshot.  It seems that even though I specified "clearpart --all   
--initlabel" it still wants to look at the partitions and gets confused if   
they don't work.   
   
At the time of the crash the old volume group (named "vg0") was active, I was   
trying to install a new volume group named "play".   
   
I will attach the anaconda crash dump. 
 
Also the crash occurs when doing a non-kickstart install. 

Version-Release number of selected component (if applicable):
fc5-pre-test1

How reproducible:
Always

Steps to Reproduce:
Create a system with an LVM snapshot and then try an install to LVM logical  
volumes on the same disk (wiping all partitions). 
  

Actual Results:  Anaconda crash. 

Additional info:
Comment 1 Russell Coker 2005-11-06 07:27:56 EST
Created attachment 120769 [details]
Anaconda dump log
Comment 2 Jeremy Katz 2005-11-07 21:50:47 EST
The lvm tools don't seem to like their own metadata

   Incorrect metadata area header checksum
  Can't remove logical volume "test" under snapshot
Comment 3 Russell Coker 2005-11-07 22:26:18 EST
I think that one might have been from the "create snap-shot on root LV and 
dead-lock your machine" problem. 
 
In any case, I specified in the kickstart config file that I wanted the entire 
partition table wiped.  Why couldn't it just wipe it without examining it? 
Comment 4 Milan Broz 2007-05-17 07:03:12 EDT
Not sure if this is still an issue, but anaconda in this case (kickstart with
option to wipe everything) should remove all possible metadata on discs, not
only partition table.

Metadata can be broken on disk and lvm will of course fail then - this is not
lvm2 bug.
Comment 5 Red Hat Bugzilla 2007-06-11 22:59:24 EDT
requested by Jams Antill
Comment 6 David Cantrell 2007-08-22 15:58:08 EDT
Is this still happening under rawhide?
Comment 7 petrosyan 2008-03-14 19:41:24 EDT
The information we've requested above is required in order
to review this problem report further and diagnose/fix the
issue if it is still present.  Since there have not been any
updates to the report since thirty (30) days or more since we
requested additional information, we're assuming the problem
is either no longer present in the current Fedora release, or
that there is no longer any interest in tracking the problem.

Setting status to "INSUFFICIENT_DATA".  If you still
experience this problem after updating to our latest Fedora
release and can provide the information previously requested, 
please feel free to reopen the bug report.

Thank you in advance.

Note You need to log in before you can comment on or make changes to this bug.