Bug 172536 - Fails to compile with reiserfs enabled
Fails to compile with reiserfs enabled
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-06 10:29 EST by Johnny Hughes
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-06 11:43:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
reiserfs patch (1.06 KB, patch)
2005-11-06 10:31 EST, Johnny Hughes
no flags Details | Diff

  None (edit)
Description Johnny Hughes 2005-11-06 10:29:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923 CentOS/1.0.7-1.4.1.centos4 Firefox/1.0.7

Description of problem:
RedHat patched the reiserfs source to change 'struct key' 
to 'struct reiserfs_key' (Patch2503) - I guess to prevent name conflicts 
with the 'Key management patches' (from the spec file).

However, it looks like they missed a couple ... not surprising as they 
don't support reiserfs, so they don't hit this problem.

The attached patch seems to allow it to compile.

Version-Release number of selected component (if applicable):
kernel-2.6.9-22.0.1.EL.src.rpm

How reproducible:
Always

Steps to Reproduce:
enable reisferfs and try to compile
  

Additional info:
Comment 1 Johnny Hughes 2005-11-06 10:31:21 EST
Created attachment 120774 [details]
reiserfs patch

This allows the kernel to compile if reiserfs is selected
Comment 2 Jason Baron 2005-11-07 13:55:48 EST
So you are using reiserfs under rhel4? As you know we don't support it...
Comment 3 Graham Leggett 2005-11-22 16:02:11 EST
Also ran into the same problem. As a result of this bug, we are unable to apply
Redhat supplied security patches to our reiserfs based systems.

Just because Redhat doesn't support reiserfs does not justify sloppy or
incomplete patching of the rest of the kernel.

If an option works in the raw kernel from kernel.org, then that same option
should work in the redhat kernel if the user chose to switch it on, even if
Redhat by default ships with a module switched off.

Note You need to log in before you can comment on or make changes to this bug.