Bug 172539 - Eclipse-cdt still not working on amd64 after eclipse-3.1.1 update
Eclipse-cdt still not working on amd64 after eclipse-3.1.1 update
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: eclipse-cdt (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnston
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-06 11:54 EST by Jeroen Beerstra
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-04 15:11:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
'hacked' Eclipse CDT finally working on amd64 (96.93 KB, image/png)
2005-11-18 15:01 EST, Jeroen Beerstra
no flags Details

  None (edit)
Description Jeroen Beerstra 2005-11-06 11:54:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); nl-NL; rv:1.7.12) Gecko/20050920 Firefox/1.0.7

Description of problem:
Plug-in "org.eclipse.cdt.core.linux.x86_64" version "3.0.0" referenced by this feature is missing

Really don't understand this: I'm pretty sure after the eclipse 3.1.1 update everything was finally working fine on my AMD64 box EXCEPT eclipse-bugzilla, "-changelog and "-pydev, which makes sense since they weren't included in the update. 

I just had to try if simply reinstalling those three would solve that. At first it looked that way, but they get disabled again when you run eclipse for the second time. To make things worse during all this eclipse-cdt get's non-functional and I haven't been able to get it to work again.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.install eclipse-cdt for fc4 from updates-released
2. start eclipse
3. goto: About->Manage Config.->CDT->status
4. It wel tell you: Plug-in "org.eclipse.cdt.core.linux.x86_64" version "3.0.0" referenced by this feature is missing
5 restart eclipse. CDT will be disabled  

Actual Results:  eclipse-cdt is non functional on amd64

Expected Results:  eclipse-cdt should work on amd64 

Additional info:

1. Again I'm not 100% sure if this also occurs if you upgrade from 3.1.0 to 3.1.1.   

2 Is it caused by this:

/usr/lib64/eclipse/plugins/org.eclipse.cdt.core.linux.x86_3.0.0/
Comment 1 Jeroen Beerstra 2005-11-18 15:01:15 EST
Created attachment 121252 [details]
'hacked' Eclipse CDT finally working on amd64

It seems there are two problems:

1 It seems eclipse-bugzilla, "-changelog, "-pydev and "-cdt need to be updated
after you install the fedora provided 3.1.1 updates. This can only be done when
you run eclipse as root, if you don't do this these plugins get disabled and
eclipse refuses to enable them since /usr/share/eclipse is not world writable.
This applies both to i386 and x86_64.

2 CDT is incorrectly build / configured for x86_64, a rpmbuild on a native
amd64 box does not help. Simply renaming everything CDT related with a x86
suffix to x86_64 and replacing all references to x86 with x86_64 in the
corresponding config files did the trick. Yes that right after many many months
I now have a fully functional 'native' Eclipse as shown on the screenshot :)

Please provide an update for problem #2.
Comment 2 Andrew Overholt 2006-01-19 14:44:27 EST
I'm sorry I haven't dealt with this yet.  I will take care of it now.

1. We're planning on releasing a new eclipse-bugzilla that will hopefully fix
that issue.  I can also re-build eclipse-changelog and eclipse-pydev to make
sure they get enabled after the 3.1.1 update (will that do it?).

2. I will investigate the CDT issues.  The CDT is a bit borked for me in general
even though a lot of the tests run fine.  Do you have issues with the indexer?
Comment 3 Jeroen Beerstra 2006-01-21 18:04:06 EST
1 I guess, dunno why this happens, but the only problem is indeed that these
plugins don't get enabled automaticly after an upgrade, nothing more nothing
less.  All my user plugins in ~/.eclipse just keep on working, but naturally
this dir is user writable, so that could be the reason.

2 Actually I don't use CDT, just installed it. But everything seems to be
working ok after my 'hack'.
Comment 4 Ben Konrath 2006-10-04 15:11:51 EDT
This bug is filed against FC4 which is no longer supported. Please re-test with
FC5 or FC6 and reopen the bug if the problem still exists. Thanks.

Note You need to log in before you can comment on or make changes to this bug.