Bug 172540 - Remove perl-dependency
Remove perl-dependency
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openvpn (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steven Pritchard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-06 13:28 EST by Enrico Scholz
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-08 10:42:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2005-11-06 13:28:12 EST
Description of problem:

Please remove the perl-dependency which is introduced by two sample scripts.
These sample scripts are samples only and are not needed for core-functionality.
Because core openvpn does not need 'perl' this dependency should be removed.

Simples way would be, to remove the 'x' bit from

| /usr/share/doc/openvpn-2.0.5/sample-scripts/auth-pam.pl
| /usr/share/doc/openvpn-2.0.5/sample-scripts/verify-cn

So, the rpm autodep generator will not generate the perl dep.


Version-Release number of selected component (if applicable):

openvpn-2.0.5-1.fc4
Comment 1 Steven Pritchard 2005-11-08 10:42:29 EST
I've changed the spec in CVS and pushed an update for rawhide, but I'm not
entirely sure this is worth pushing an update for FC3 and FC4.

Please let me know if this is causing a real problem for you.  Otherwise, the
fix will be in the next stable update.

Note You need to log in before you can comment on or make changes to this bug.