Bug 1725517 - Set `ENABLE_PROMETHEUS_ENDPOINT=false` in rsyslog env doesn't take effect.
Summary: Set `ENABLE_PROMETHEUS_ENDPOINT=false` in rsyslog env doesn't take effect.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.3.0
Assignee: Jeff Cantrill
QA Contact: Qiaoling Tang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-01 02:50 UTC by Qiaoling Tang
Modified: 2020-01-23 11:04 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-23 11:04:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-logging-operator pull 224 0 None closed Bug 1725517: Setting ENABLE_PROMETHEUS_ENDPOINT=false in rsyslog env doesn't take effect. 2020-10-07 16:14:37 UTC
Red Hat Product Errata RHBA-2020:0062 0 None None None 2020-01-23 11:04:40 UTC

Description Qiaoling Tang 2019-07-01 02:50:30 UTC
Description of problem:
The default value of ENABLE_PROMETHEUS_ENDPOINT is false(https://github.com/openshift/cluster-logging-operator/blob/master/files/rsyslog/rsyslog.sh#L4), when deploying logging using rsyslog as log collector, some of the rsyslog pods' prometheus endpoints are exposed.

If set ENABLE_PROMETHEUS_ENDPOINT=true in rsyslog ds, then wait for all rsyslog pods restart, set ENABLE_PROMETHEUS_ENDPOINT=false again, all of the rsyslog pods prometheus endpoints are exposed.

[qitang@wlc-trust-182 aws]$ oc exec rsyslog-t7rqb env |grep ENABLE_PROMETHEUS_ENDPOINT
Defaulting container name to rsyslog.
Use 'oc describe pod/rsyslog-t7rqb -n openshift-logging' to see all of the containers in this pod.
ENABLE_PROMETHEUS_ENDPOINT=false
[qitang@wlc-trust-182 aws]$ oc exec rsyslog-t7rqb -- curl -k https://localhost:24231/metrics
Defaulting container name to rsyslog.
Use 'oc describe pod/rsyslog-t7rqb -n openshift-logging' to see all of the containers in this pod.
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 13285    0 13285    0     0   102k      0 --:--:-- --:--:-- --:--:--  103k
# HELP go_gc_duration_seconds A summary of the GC invocation durations.
# TYPE go_gc_duration_seconds summary
go_gc_duration_seconds{quantile="0"} 5.9918e-05
go_gc_duration_seconds{quantile="0.25"} 5.9918e-05
go_gc_duration_seconds{quantile="0.5"} 5.9918e-05
go_gc_duration_seconds{quantile="0.75"} 5.9918e-05
go_gc_duration_seconds{quantile="1"} 5.9918e-05
go_gc_duration_seconds_sum 5.9918e-05
go_gc_duration_seconds_count 1
# HELP go_goroutines Number of goroutines that currently exist.
# TYPE go_goroutines gauge
go_goroutines 14
# HELP go_info Information about the Go environment.
# TYPE go_info gauge
<------>

Version-Release number of selected component (if applicable):
ose-logging-rsyslog-v4.2.0-201906301800

How reproducible:
Always

Steps to Reproduce:
1.Deploy logging via OLM
2.check targets in prometheus console
3.

Actual results:
ENABLE_PROMETHEUS_ENDPOINT=false in rsyslog pod doesn't take effect

Expected results:
If set ENABLE_PROMETHEUS_ENDPOINT=false, should not expose any rsyslog prometheus endpoints.

Additional info:
Could we set ENABLE_PROMETHEUS_ENDPOINT default to true?

Comment 2 Qiaoling Tang 2019-08-05 01:52:36 UTC
Verified with ose-cluster-logging-operator-v4.2.0-201908041300

Comment 6 errata-xmlrpc 2020-01-23 11:04:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.