Bug 17256 - getfh failed: Operation not permitted
getfh failed: Operation not permitted
Product: Red Hat Linux
Classification: Retired
Component: nfs-server (Show other bugs)
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Cristian Gafton
Depends On:
  Show dependency treegraph
Reported: 2000-09-05 12:00 EDT by Harald Welte
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-09-05 12:00:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Harald Welte 2000-09-05 12:00:33 EDT
I'm running various RHL based nfs servers using RHL 6.2 and all the updated
packages from redhat-updates (kernel 2.2.16-3). Never encountered any
problems so far. 

But today I wanted to remount one of the nfs server's exports and the
client said permission denied.

Syslog of server showed something strange:

Sep  5 15:55:04 hoth mountd[25417]: authenticated mount request from
exodus.towersoft.de:849 for /raid/compaq1/rpms (/raid/compaq1/rpms)
Sep  5 15:55:05 hoth mountd[25417]: getfh failed: Operation not permitted 

/etc/rc.d/init.d/nfs restart solved the problem
Comment 1 Cristian Gafton 2000-09-06 10:31:28 EDT
Let's just hope that the new nfs-utils that we'll start using in the next
release will behave better.

For now I will close with worksforme, at least until we can get a test case we
can reproduce.
Comment 2 D. Hugh Redelmeier 2000-11-03 13:58:23 EST
I had a similar problem.  An up-to-date RHL7.0 NFS client of an up-to-date
RHL6.2 NFS server.  Same error message.  Restarting NFS on server didn't help. 
"exportfs -r -v" on server printed very odd lines at end:
 exporting redbook.mimosa.com:/ to kernel
 redbook.mimosa.com:/: Invalid argument
"redbook" is the client's name and is not mentioned explicitly in /etc/exports.

I had to empty the file /var/lib/nfs/rmtab on the server (strace is your
Further details upon request.
Comment 3 Need Real Name 2001-06-27 21:20:43 EDT
I've had this same problem the last few days.  It was fixed by removing all wild
card type entries from /etc/exports.  I did have at various stages:

/dir	*(rw)

both of which I thought were legal (at least the man page seems to say this).

Note You need to log in before you can comment on or make changes to this bug.