Bug 172560 - /etc/X11/xdm/Xsession is needed by package gdm
/etc/X11/xdm/Xsession is needed by package gdm
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Mike McLean
:
Depends On:
Blocks: xorg-bad-deps
  Show dependency treegraph
 
Reported: 2005-11-07 05:08 EST by Nicolas Mailhot
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-14 17:57:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2005-11-07 05:08:05 EST
/etc/X11/xdm/Xsession is needed by package gdm
xinitrc >= 0:3.33-1 is needed by package gdm

gdm-2.8.0.4-8
Comment 1 Mike A. Harris 2005-11-13 04:02:44 EST
The generic Red Hat Xsession script is now owned by the xorg-x11-xinit
package, which contains:

Provides: xinitrc = 5.0.0-1

The reason it was kept in the xinit package instead of being coupled with
xdm is twofold:

1) The 'xinitrc' and 'Xsession' scripts used to share a lot of code which
   got out of sync very often as a bugfix was applied to one file, but not
   the other.  I split out their common code into 'xinitrc-common' which
   both of them source.  It is easiest to maintain them in one package
   rather than two.

2) I believe both gdm and kdm use xdm's Xsession script.  It is better to
   have it in the xinit package, so that gdm/kdm do not have to have a
   hard dependency on xdm for the script to be installed.

That coupled with the above virtual provide I mentioned, means gdm/kdm
should work fine by doing 'Requires: xinitrc', at least for the time
being.

Note however, that the monolithic tree with xinitrc, has a number of files
with hard coded paths set in /usr/X11R6, whereas the new xorg-x11-xinit
package has all of the paths set to /usr.  If this is a problem for gdm
or kdm, I can review the scripts and have them check /usr/bin first, and
fall back to looking in /usr/X11R6.
Comment 2 Jeremy Katz 2005-11-14 17:57:25 EST
Fixed

Note You need to log in before you can comment on or make changes to this bug.