Bug 172567 - cannot find -lXext when compiling xine-lib, version 57 worked
cannot find -lXext when compiling xine-lib, version 57 worked
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-07 06:36 EST by Knut J BJuland
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-13 01:42:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Knut J BJuland 2005-11-07 06:36:43 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051102 Fedora/1.5-0.5.0.rc1 Firefox/1.5

Description of problem:
When I am compiing xine-lib from freshrpms, %configure \    --x-includes=/usr/X11R6/includes \
    --x-libraries=/usr/X11R6/lib \
    --enable-ipv6 \
    %{?_with_extffmpeg:--with-external-ffmpeg} \
    %{?_without_alsa:--disable-alsa} \
    %{!?_with_extdvdnav:--with-included-dvdnav}

with thesse option i am unale to link aginst -lXext

Version-Release number of selected component (if applicable):
59

How reproducible:
Always

Steps to Reproduce:
1.rpmbuild --rebuild xine-lib-from-freshrpmlatest.src.rpm
2.
3.
  

Actual Results:  does not compile

Expected Results:  worked with version 57.

Additional info:
Comment 1 Knut J BJuland 2005-11-12 03:33:28 EST
I have installed xorg-x11-devel, I am able to compile xine-lib cvs by using
-I/usr/X11R6/include/X11/extensions/Xext.h instead off -lXext and disabling
Imagemagic. I have alos issued /sbin/ldconfig -v /usr/X11R6/lib as root.
Comment 2 Mike A. Harris 2005-11-13 01:42:18 EST
libXext is provided in xorg-x11-libs, and the .so symlink is provided in the
xorg-x11-devel package, as they always have been.  This has not changed in
rawhide.

You should consult with the Xine developers for the problem you are
experiencing, as this is not a bug in X.

Just as a heads up however, you should not hard code where the X libraries
and include files are, because they are not in that location in X11R7, which
is what Fedora Core 5 will be switching to very soon.

Setting status to "NOTABUG".

Note You need to log in before you can comment on or make changes to this bug.