Bug 1725977 - Unable to create a release image with new manifests
Summary: Unable to create a release image with new manifests
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cluster Version Operator
Version: 4.1.z
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.3.0
Assignee: Abhinav Dahiya
QA Contact: liujia
URL:
Whiteboard:
Depends On:
Blocks: 1725978
TreeView+ depends on / blocked
 
Reported: 2019-07-01 22:27 UTC by Alex Crawford
Modified: 2020-01-23 11:04 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1725978 (view as bug list)
Environment:
Last Closed: 2020-01-23 11:04:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift oc pull 147 'None' closed Bug 1725977: admin/release/new: always consider all mappings 2020-03-18 04:58:22 UTC
Red Hat Product Errata RHBA-2020:0062 None None None 2020-01-23 11:04:40 UTC

Description Alex Crawford 2019-07-01 22:27:06 UTC
Description of problem:
When using `oc adm release new`, I'm unable to add a new operator using an override.

Version-Release number of selected component (if applicable):
$ oc version
Client Version: version.Info{Major:"4", Minor:"1+", GitVersion:"v4.1.0-201905191700+7bd2e5b-dirty", GitCommit:"7bd2e5b", GitTreeState:"dirty", BuildDate:"2019-05-19T23:52:43Z", GoVersion:"go1.11.5", Compiler:"gc", Platform:"linux/amd64"}
Server Version: version.Info{Major:"1", Minor:"11+", GitVersion:"v1.11.0+d4cacc0", GitCommit:"d4cacc0", GitTreeState:"clean", BuildDate:"2019-05-02T11:52:09Z", GoVersion:"go1.10.8", Compiler:"gc", Platform:"linux/amd64"}

How reproducible:
Always

Steps to Reproduce:
1. oc adm release new --from-release registry.svc.ci.openshift.org/origin/release:4.2 --to-dir release-image cluster-etcd-operator=quay.io/hexfusion/cluster-etcd-operator:latest
2. fd 0000_12 release-image

Actual results:
No manifests from the etcd operator are present in the directory.

Expected results:
$ fd 0000_12 release-image
release-image/0000_12_etcd-operator_00_namespace.yaml
release-image/0000_12_etcd-operator_01_cluster-member-request-crd.yaml
release-image/0000_12_etcd-operator_01_config.crd.yaml
release-image/0000_12_etcd-operator_01_operator.cr.yaml
release-image/0000_12_etcd-operator_02_service.yaml
release-image/0000_12_etcd-operator_03_configmap.yaml
release-image/0000_12_etcd-operator_04_clusterrolebinding.yaml
release-image/0000_12_etcd-operator_05_serviceaccount.yaml
release-image/0000_12_etcd-operator_06_deployment.yaml
release-image/0000_12_etcd-operator_07_clusteroperator.yaml

Additional info:
Patch is here: https://github.com/openshift/oc/pull/2

Comment 1 Abhinav Dahiya 2019-07-03 00:53:33 UTC
The override is not used to find the operators that need to be included in the release-image, but only to override the already included operators.
The --from-* are responsible for choosing the operators that need to end up in release image.

using the overrides to also affect what operators end up should probably be an RFE. https://jira.coreos.com/secure/RapidBoard.jspa?rapidView=165&view=detail

Comment 2 Alex Crawford 2019-07-08 18:09:11 UTC
So what is the process today? Is there a doc I missed?

Comment 3 Alex Crawford 2019-07-24 18:29:44 UTC
From slack:

> crawford: What do you think about https://github.com/openshift/origin/issues/21061? Is this a bug that needs to be fixed or is it my understanding of how release images should be built.
> Clayton Coleman: it’s definitely bug, should have been fixed

I'm gonna reopen this.

Comment 5 liujia 2019-11-12 06:48:44 UTC
Version:
# ./oc version
Client Version: openshift-clients-4.3.0-201910250623-48-g8c30708e
Kubernetes Version: v1.11.0+d4cacc0

Steps:
1. docker login
2. # ./oc adm release new --from-release registry.svc.ci.openshift.org/ocp/release:4.3.0-0.nightly-2019-11-12-000306 --to-dir release-image cluster-etcd-operator=quay.io/hexfusion/cluster-etcd-operator:latest
...
info: Loading override quay.io/hexfusion/cluster-etcd-operator:latest cluster-etcd-operator
...
# ls release-image/ |grep "0000_12"
0000_12_etcd-operator_00_namespace.yaml
0000_12_etcd-operator_00_staticpod-rolebinding.yaml
0000_12_etcd-operator_00_staticsync-rolebinding.yaml
0000_12_etcd-operator_01_config.crd.yaml
0000_12_etcd-operator_01_operator.cr.yaml
0000_12_etcd-operator_02_service.yaml
0000_12_etcd-operator_03_configmap.yaml
0000_12_etcd-operator_03_secret.yaml
0000_12_etcd-operator_04_clusterrolebinding.yaml
0000_12_etcd-operator_05_serviceaccount.yaml
0000_12_etcd-operator_06_deployment.yaml
0000_12_etcd-operator_06_static_pod_demonset.yaml
0000_12_etcd-operator_06_static_sync_demonset.yaml
0000_12_etcd-operator_07_clusteroperator.yaml

Comment 7 errata-xmlrpc 2020-01-23 11:04:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.