Bug 1726056 - The generated configmap in openshift-config lost data content when creating OAuth by console
Summary: The generated configmap in openshift-config lost data content when creating O...
Keywords:
Status: CLOSED DUPLICATE of bug 1727282
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-02 07:02 UTC by XiaochuanWang
Modified: 2019-07-05 16:23 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-05 16:23:09 UTC
Target Upstream Version:


Attachments (Terms of Use)
Created configmap lost data content (33.01 KB, image/png)
2019-07-02 07:02 UTC, XiaochuanWang
no flags Details

Description XiaochuanWang 2019-07-02 07:02:34 UTC
Created attachment 1586538 [details]
Created configmap lost data content

Description of problem:
Cluster admin user create an Oauth by console, upload a file as CA file. The generated configmap in project openshift-config lost content

Version-Release number of selected component (if applicable):
4.2.0-0.nightly-2019-06-30-221852
image for openshift-console: quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:cfb2ff43b6b9696d21c755b791174a0a35f187dc3544823547e12c45726adc8d

How reproducible:
Always

Steps to Reproduce:
1. Cluster admin login and go to the Oauth page -> Add -> Basic Authentication
2. Set url, upload a pem file to CA File
3. Check the generated configmap from openshift-config
Check the pod from openshift-authentication.

Actual results:
Created configmap lost data content (the data is empty). New created pods from openshift-authentication can not be ready. (Please refer to the screenshot)

Expected results:
Created secret under openshift-config should be like below. The key of configmap should be "ca.crt", the data value should be content of CA File:
"""
kind: ConfigMap
apiVersion: v1
metadata:
  name: basic-auth-ca-4ftmx
  namespace: openshift-config
  ...
data:
  ca.crt: |
    -----BEGIN CERTIFICATE-----
    MIIC6jCCAdKgAwIBAgIBATANBg...
    ...
    cnbCbVQLPIEzo1BzOTAvmtXUel...
    -----END CERTIFICATE-----
"""

Additional info:
Expected configmap refer to `oc create configmap basic-auth-ca-4ftmx  --from-file=ca.crt=tls-ca-bundle.pem`

Comment 1 Samuel Padgett 2019-07-05 16:23:09 UTC

*** This bug has been marked as a duplicate of bug 1727282 ***


Note You need to log in before you can comment on or make changes to this bug.