Bug 172617 - Remove .la files from neon-devel
Summary: Remove .la files from neon-devel
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: neon   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-11-07 20:36 UTC by Kjartan Maraas
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-07 20:56:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kjartan Maraas 2005-11-07 20:36:39 UTC
Description of problem:

.la files aren't strictly needed on Linux and causes a lot of problems when
compiling since they hardcode absolute paths to dependent libraries.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Joe Orton 2005-11-07 20:56:45 UTC
Please everyone stop filing these bugs and go fix actual problems rather than
papering over the symptoms.  The .la files are part of the interface.

Comment 2 Kjartan Maraas 2005-11-07 22:45:49 UTC
Well there seems to be agreement on this among a lot of your fellow colleagues
and after talking with no less than four or five of them about this I decided to
file bugs against the remaining ones I could find on my system. They've already
been removed from 80% of the existing packages in fedora from what I can see, so
how can the remaining 20% be part of the interface?

Comment 3 Joe Orton 2005-11-08 09:32:42 UTC
There are two cases it breaks:

1) where the package uses the .la file as a well-defined portable interface to
link against the library (`neon-config --la-file`)

2) where other applications will use ltdl to open the library

and you need to first determine whether or not one of these cases applies before
 filing these blanket "remove the .la file" requests.

Comment 4 Kjartan Maraas 2005-11-08 11:25:19 UTC
Ok, thanks for the clarification and sorry for any noise created by filing these
bugs.


Note You need to log in before you can comment on or make changes to this bug.