Bug 172619 - Remove .la file from tetex
Remove .la file from tetex
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: tetex (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-07 15:39 EST by Kjartan Maraas
Modified: 2013-07-02 19:10 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-09 06:26:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kjartan Maraas 2005-11-07 15:39:18 EST
Description of problem:

.la files aren't strictly needed on Linux and causes a lot of problems when
compiling since they hardcode absolute paths to dependent libraries.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jindrich Novy 2005-11-08 04:30:56 EST
I don't see anything bad with libkpathsea.la, the only .la file shipped with the
teTeX package.
Comment 2 Jindrich Novy 2005-11-08 04:34:02 EST
This may require fixing on libtool side instead of removing la files from every
package.
Comment 3 Jindrich Novy 2005-11-08 09:40:40 EST
On second thought it's better to see it removed from teTeX.
Comment 4 Jindrich Novy 2005-11-09 06:26:54 EST
Removed since tetex-3.0-9

Note You need to log in before you can comment on or make changes to this bug.