Bug 172638 - Remove .la file from k3b
Remove .la file from k3b
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: k3b (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-07 15:57 EST by Kjartan Maraas
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-16 08:37:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kjartan Maraas 2005-11-07 15:57:04 EST
Description of problem:

.la files aren't strictly needed on Linux and causes a lot of problems when
compiling since they hardcode absolute paths to dependent libraries.

Version-Release number of selected component (if applicable):



How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Michael Schwendt 2006-03-15 15:26:01 EST
Bad. Incomplete removal! There are further libtool archives in the
package which contain references to the removed files %{_libdir}/libk3b.la
and %{_libdir}/libk3bdevice.la. This makes these files useless, because it
breaks them. Either remove them all or keep them all. Do not break the
dependency chain!

$ rpm -ql k3b | grep .la\$
/usr/lib/kde3/libk3balsaoutputplugin.la
/usr/lib/kde3/libk3bartsoutputplugin.la
/usr/lib/kde3/libk3bexternalencoder.la
/usr/lib/kde3/libk3bflacdecoder.la
/usr/lib/kde3/libk3boggvorbisdecoder.la
/usr/lib/kde3/libk3boggvorbisencoder.la
/usr/lib/kde3/libk3bsoxencoder.la
/usr/lib/kde3/libk3bwavedecoder.la
Comment 2 Michael Schwendt 2006-03-15 16:07:59 EST
And since the plugin .la files are still needed in order to not
break loading the plugins, it is even more questionable to remove
the k3b core .la files.
Comment 3 Michael Schwendt 2006-03-16 08:37:08 EST
Re-closing the bug. More comments about this on fedora-extras-list

Note You need to log in before you can comment on or make changes to this bug.