Bug 172639 - libidn: remove libidn.la
libidn: remove libidn.la
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libidn (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-07 15:58 EST by Kjartan Maraas
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.6.2-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-01 06:20:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kjartan Maraas 2005-11-07 15:58:07 EST
Description of problem:

.la files aren't strictly needed on Linux and causes a lot of problems when
compiling since they hardcode absolute paths to dependent libraries.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Joe Orton 2005-11-08 04:24:36 EST
See also other NOTABUGs.
Comment 2 Warren Togami 2005-11-08 13:45:52 EST
Hi Joe, Bug #145879 seems to be the only other NOTABUG for libidn.  It is
unclear to me from this why keeping the .la file is desired.  Is there some
other report that you meant?
Comment 3 Joe Orton 2005-11-08 17:10:31 EST
There reference was to the other identical bugs Kjartan was filing against my
packages.   This is not a bug.  Removing the .la file will break KDE, which
ltdlopen()s this library.  The libidn.la file should continue to be packaged. 
Really. :)
Comment 4 Rex Dieter 2006-05-11 08:58:52 EDT
Joe, including .la files generally goes against the now-to-be-used Packaging
Guidelines (http://fedoraproject.org/wiki/Packaging/Guidelines, "14. Exclusion
of static libraries".  Reopening.

And no, it won't break KDE (kde-redhat has been omitting libidn.la for *ages*).
 At most KDE would need to be rebuilt after libidn omitted the .la file.  See
also bug #170602 for another easy way for KDE to avoid breakage *without* having
to rebuilt.

Even if you're hesitant to make this change for *current* FC releases (it would
introduce binary incompatibility from existing/previous libidn pkg releases),
please seriously consider this for devel/fc6.
Comment 5 Joe Orton 2006-05-11 09:02:33 EDT
It is not the fact that any KDE .la file references libidn.la which makes this
problematic.  My understanding is that KDE uses ltdlopen() to load libidn at
runtime, which requires the presence of the .la file - at runtime - to work
correctly.  Please convince me that is not the case.
Comment 6 Rex Dieter 2006-05-11 09:09:05 EDT
AFAIK, kdelibs simply links against libusb, no ltdlopen() involved.  Regardless,
even *if* ltdlopen is used, it will look for libusb.la first, and if not found,
try to load libusb.so, but, oops, that's in libusb-devel (right?).  Lemme go
check my facts.
Comment 7 Rex Dieter 2006-05-11 09:11:21 EDT
On second thought, I'm 99% sure you're wrong.  If you were right, any KDE user
without libidn-devel installed (ie, where libidn.la is), would have a broken
system (ie, not being able to ltdlopen() libidn.la), right?
Comment 8 Rex Dieter 2006-05-11 09:13:04 EDT
Oops, nevermind, you include libidn.la in the core pkg... because of the runtime
ltdlopen?
Comment 9 Joe Orton 2006-05-11 09:14:57 EDT
Yes, that is my understanding.  Education welcome.

* Tue Jun 22 2004 Than Ngo <than@redhat.com> 0.4.9-2
- add prereq: /sbin/ldconfig
- move la file in main package
Comment 10 Rex Dieter 2006-05-11 09:18:59 EDT
Can't find any references to loading libidn at runtime in kdelibs, only standard
linking.  Than, comment?

If you're still concerned about the runtime loading, you could still omit
libidn.la and include libidn.so in the main pkg to accomplish the same thing.
Comment 11 Rex Dieter 2006-05-30 09:44:32 EDT
Joe, due to Than's silence, my opinion is "just do it", and see if anything
breaks, and I don't think anything will.
Comment 12 Ngo Than 2006-05-30 11:51:31 EDT
Joe, you can remove *.la from libidn for FC6. Thanks
Comment 13 Joe Orton 2006-06-01 06:20:20 EDT
OK, thanks guys.

Note You need to log in before you can comment on or make changes to this bug.