Bug 172670 - gnome-pilot will not perform inital sync with USB Palm, even after udev has been updated
gnome-pilot will not perform inital sync with USB Palm, even after udev has b...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-pilot (Show other bugs)
4
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-07 20:41 EST by John Curcio
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: gnome-pilot-2.0.15-1.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-18 10:15:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Curcio 2005-11-07 20:41:18 EST
Description of problem: Gnome-pilot never gets username/UserID from USB Palm
Pilot (T3) 


Version-Release number of selected component (if applicable):
pilot-link - pilot-link-0.12.0-0.pre4.0.fc4.2
gnome-pilot - gnome-pilot-2.0.13-5.fc4
udev - udev-058-1.0.FC4.1


How reproducible:


Steps to Reproduce:
1. start GUI for gnome-pilot (desktop, preferences, more preferences, PalmOS
Devices)
2. step through first time menu, selecting /dev/ttyUSB1 and USB-type [same
results when selecting /dev/pilot and/or serial device]
3. start hot-sync app on palm pilot
  
Actual results:
Palm eventually gives up with failed connection.

Expected results:
gnome-pilot should obtain username and User ID.

Additional info:
Have read and re-read http://www.clasohm.com/blog/one-entry?entry_id=12096 and
have created file /etc/udev/rules/10-visor.rules with following line => 
KERNEL="ttyUSB[13579]", SYMLINK="pilot"

I do see the following device files =>
[root@localhost rules.d]# ls -sl /dev/ttyUSB*
0 crw-rw----  1 root    uucp 188, 0 Nov  7 20:29 /dev/ttyUSB0
0 crw-------  1 jcurcio uucp 188, 1 Nov  7 20:29 /dev/ttyUSB1
[root@localhost rules.d]# ls -sl /dev/pilot
0 lrwxrwxrwx  1 root root 7 Nov  7 20:29 /dev/pilot -> ttyUSB1

and /var/log/messages shows => 
Nov  7 20:31:08 localhost kernel: ohci_hcd 0000:00:02.3: wakeup
Nov  7 20:31:08 localhost kernel: usb 2-1: new full speed USB device using
ohci_hcd and address 24
Nov  7 20:31:09 localhost kernel: visor 2-1:1.0: Handspring Visor / Palm OS
converter detected
Nov  7 20:31:09 localhost kernel: usb 2-1: Handspring Visor / Palm OS converter
now attached to ttyUSB0
Nov  7 20:31:09 localhost kernel: usb 2-1: Handspring Visor / Palm OS converter
now attached to ttyUSB1
Nov  7 20:32:14 localhost kernel: usb 2-1: USB disconnect, address 24
Nov  7 20:32:14 localhost kernel: visor ttyUSB0: Handspring Visor / Palm OS
converter now disconnected from ttyUSB0
Nov  7 20:32:14 localhost kernel: visor ttyUSB1: Handspring Visor / Palm OS
converter now disconnected from ttyUSB1
Nov  7 20:32:14 localhost kernel: visor 2-1:1.0: device disconnected

I am able to sync with jpilot, but have never been able to sync with gnome-pilot.

I am still running FC3 as my main machine, but cannot upgrade to FC4 until this
is working. This is very frustrating and disappointing ...

[Please understand this is nothing personal, but this is soooo frustrating! I
have had problems with intial syncs to Palm Pilots in RH version after version
after version for year after year. When I try the same thing on Ubuntu, Suse,
Debian or even Mandrake I have NEVER had any problems. What makes it worse, is
for those of us who use this feature, it is absolutely "mission critical". I
love Red Hat/Fedora, but issues like this seriously make me consider switching
... something I truly do not want to do.]
Comment 1 Matt Davey 2006-01-05 07:35:43 EST
please try starting /usr/libexec/gpilotd in a terminal window before
starting the config applet, as that'll let you see additional debug
messages.

please try setting the timeout parameter to zero and retrying
(I believe what you are seeing may be an issue with timeout
code, usb/visor.o and pilot-link code post July 20th)
Comment 2 John Curcio 2006-01-05 21:07:33 EST
How do I set the timeout parameter? I don' see any man page, gpilot --help
doesn't show it, and there isn't any documentation in /usr/share/gpilotd, nor is
there anything useful in /usr/share/doc/*pilot*

I ran gpilotd from the CLI prompt and got the following =>

[jcurcio@localhost ~]$ /usr/libexec/gpilotd
gpilotd-Message: gnome-pilot 2.0.13 starting...
gpilotd-Message: compiled for pilot-link version 0.12.0-pre3
gpilotd-Message: compiled with [VFS] [USB] [IrDA] [Network]

(gpilotd:3095): gpilotd-WARNING **: Number of devices is configured to 0

(gpilotd:3095): gpilotd-WARNING **: No accessible devices available

(gpilotd:3095): gpilotd-WARNING **: Number of pilots is configured to 0
gpilotd-Message: Activating CORBA server
gpilotd-Message: bonobo_activation_active_server_register = 0

While it was waiting for something, I checked and then modified the permissions
on the appropiate file, as you can see =>

[root@localhost ~]# ls -sl /dev/ttyUSB1
0 crw-------  1 jcurcio uucp 188, 1 Jan  5 21:00 /dev/ttyUSB1
[root@localhost ~]# chmod 666 !$
chmod 666 /dev/ttyUSB1
[root@localhost ~]# ls -sl /dev/ttyUSB1
0 crw-rw-rw-  1 jcurcio uucp 188, 1 Jan  5 21:00 /dev/ttyUSB1

In the end, nothing happened. The Palm eventually gave up and I had to crash out
of gpilotd.

Does this help? Is there anything I can try at the end of the weekend?
Comment 3 Matt Davey 2006-01-06 05:03:55 EST
Sorry, I could have been more specific.
By the way, I agree with you on the lack of documentation on gnome-pilot,
but like a lot of other frustrated users, I never did anything about it
once I got stuff figured out.

Anyway, back to your problem.
Thanks for the listing above.  The 'timeout' parameter is available as part of
the configuration applet, on the same panel in which you get to specify the port
and type (serial/usb/irda/network).

Did you run the configuration applet after starting gpilotd in a terminal
window, as suggested?  It doesn't look like it from the output you sent.
I suggested starting up gpilotd by hand because then you get to see output that
would be hidden from you if gpilotd was started by the configuration gui.
Comment 4 John Curcio 2006-01-06 08:04:37 EST
That did it! Finally! At long last I can move up to FC-4 [... just when I was
starting to loose hope]. Thank you ... you help was MUCH appreciated!
Comment 5 Matthew Barnes 2006-12-18 10:15:14 EST
Closing this bug since it looks like comment #3 has the solution.

Feel free to re-open this if the problem still exists in Fedora Core 6 using
gnome-pilot-2.0.15.

Note You need to log in before you can comment on or make changes to this bug.