This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 172671 - system-config-soundcard crashes with short soundcard descriptions
system-config-soundcard crashes with short soundcard descriptions
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-soundcard (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-07 21:13 EST by Paco Soberón
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-09 07:58:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (570 bytes, patch)
2005-11-07 21:13 EST, Paco Soberón
no flags Details | Diff

  None (edit)
Description Paco Soberón 2005-11-07 21:13:49 EST
Description of problem:
After installing my new USB camera, system-config-soundcard crashes at startup.

Traceback (most recent call last):
  File "/usr/share/system-config-soundcard/system-config-soundcard.py", line 46,
in ?
    app = soundcard.childWindow()
  File "/usr/share/system-config-soundcard/soundcard.py", line 87, in __init__
    self.device, self.module, self.maker, self.model =
self.soundcardBackend.getData(card)
  File "/usr/share/system-config-soundcard/soundcardBackend.py", line 106, in
getData
    maker, model = string.split(description, " ", 1)
ValueError: unpack list of wrong size

The problem is that description of my USB camera is very short: it has only one
word. So the list returned by split function has only one element, and cannot be
assigned to the tuple (maker, model). A similar problem would arise if the
description was an empty string.

I send attached a working (at least for me) patch.

Version-Release number of selected component (if applicable):
I'm using system-config-soundcard-1.2.10-1 on FC3

How reproducible:
Always
Comment 1 Paco Soberón 2005-11-07 21:13:50 EST
Created attachment 120800 [details]
Proposed patch
Comment 2 Martin Stransky 2005-11-09 07:58:25 EST
It should be fixed in devel (package system-config-soundcard-1_2_14-1)

Note You need to log in before you can comment on or make changes to this bug.