Bug 172674 - fonts not loaded after fresh install
fonts not loaded after fresh install
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: fontconfig (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Carl Worth
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-08 00:41 EST by Lawrence Lim
Modified: 2014-03-25 20:52 EDT (History)
2 users (show)

See Also:
Fixed In Version: fontconfig-2.3.92-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-08 01:43:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lawrence Lim 2005-11-08 00:41:48 EST
Description of problem:
After a fresh install with ja language, the whole Desktop was blank because the
font was loaded.

Version-Release number of selected component (if applicable):
fontconfig-devel-2.3.91.cvs20051031-1
fontconfig-2.3.91.cvs20051031-1

How reproducible:
Always

Steps to Reproduce:
1.install rawhide in ja locale
2.start GNOME desktop
3.
  
Actual results:
Blank no text

Expected results:
ja fonts loaded 

Additional info:
Got it working by using the following command.

# fc-cache -f -v /usr/share/fonts
fc-cache: "/usr/share/fonts": caching, 0 fonts, 4 dirs
fc-cache: "/usr/share/fonts/japanese": caching, 0 fonts, 2 dirs
fc-cache: "/usr/share/fonts/japanese/misc": caching, 84 fonts, 0 dirs
fc-cache: "/usr/share/fonts/japanese/TrueType": caching, 2 fonts, 0 dirs
fc-cache: "/usr/share/fonts/default": caching, 0 fonts, 2 dirs
fc-cache: "/usr/share/fonts/default/Type1": caching, 35 fonts, 0 dirs
fc-cache: "/usr/share/fonts/default/ghostscript": caching, 17 fonts, 0 dirs
fc-cache: "/usr/share/fonts/bitstream-vera": caching, 10 fonts, 0 dirs
fc-cache: "/usr/share/fonts/bitmap-fonts": caching, 32 fonts, 0 dirs
fc-cache: succeeded
Comment 1 Lawrence Lim 2005-11-08 00:47:19 EST
Think it could be related to the drop of timestamp.patch.

July 23 2005 Kristian Høgsberg <krh@redhat.com> - 2.3.2-1
- Update to fontconfig-2.3.2.  Drop

        fontconfig-2.1-slighthint.patch,
        fontconfig-2.2.3-timestamp.patch,
        fontconfig-2.2.3-names.patch,
        fontconfig-2.2.3-ta-pa-orth.patch, and
        fontconfig-2.2.3-timestamp.patch,

  as they are now merged upstream.

Comment 2 Lawrence Lim 2005-11-08 01:43:39 EST
Apparently, my rawhide is not 'raw' enough. fontconfig-2.3.92-1 has fixed the issue.

Note You need to log in before you can comment on or make changes to this bug.