Bug 1726866 - invalid machine config should cause a RenderDegraded error not NodeDegraded
Summary: invalid machine config should cause a RenderDegraded error not NodeDegraded
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Machine Config Operator
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.1.z
Assignee: Kirsten Garrison
QA Contact: Micah Abbott
URL:
Whiteboard:
Depends On: 1727104
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-03 22:44 UTC by Kirsten Garrison
Modified: 2019-08-28 19:54 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1727104 (view as bug list)
Environment:
Last Closed: 2019-08-28 19:54:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift machine-config-operator pull 989 None None None 2019-07-18 20:26:07 UTC
Red Hat Product Errata RHBA-2019:2547 None None None 2019-08-28 19:54:54 UTC

Description Kirsten Garrison 2019-07-03 22:44:05 UTC
Description of problem:
An invalid machine config should cause a RenderDegraded error not NodeDegraded

How reproducible:
Apply an invalid machineconfig and note that while there is an error it is NodeDegraded and NOT the expected/correct RenderDegraded

Steps to Reproduce:
1.Apply an invalid machineconfig for example:
apiVersion: machineconfiguration.openshift.io/v1
kind: MachineConfig
metadata:
  labels:
    machineconfiguration.openshift.io/role: worker
  name: 50-examplecorp-chrony
spec:
  config:
    ignition:
      version: 2.2.0
    storage:
      files:
      - contents:
          source: data:text/plain;charset=utf;base64,c2VydmVyIGZvby5leGFtcGxlLm5ldCBtYXhkZWxheSAwLjQgb2ZmbGluZQpzZXJ2ZXIgYmFyLmV4YW1wbGUubmV0IG1heGRlbGF5IDAuNCBvZmZsaW5lCnNlcnZlciBiYXouZXhhbXBsZS5uZXQgbWF4ZGVsYXkgMC40IG9mZmxpbmUK
        mode: 0644
        path: /etc/chrony.conf
2. oc describe mcp worker

Actual results:
Node Degraded

Expected results:
Render Degraded

Comment 1 Kirsten Garrison 2019-07-03 22:44:58 UTC
This will be fixed in master via https://github.com/openshift/machine-config-operator/pull/899 (currently pending merge)

Comment 2 Kirsten Garrison 2019-07-03 22:51:36 UTC
Sorry wrong link above..

This will be fixed in master pending https://github.com/openshift/machine-config-operator/pull/894 being merged.

Comment 3 Antonio Murdaca 2019-07-18 11:04:43 UTC
I'm not sure this is severe enough from a backport but let's open a 4.1 backport and have architects decide

Comment 10 Antonio Murdaca 2019-08-23 16:17:06 UTC
I'm not sure either why this wasn't moved to MODIFIED once the PR got merged (maybe the bot functionality wasn't there at the time I seem to remember). So it should have been in MODIFIED, and you also already verified it as per https://bugzilla.redhat.com/show_bug.cgi?id=1726866#c6 so it should be safe to move this to VERIFIED.

Comment 12 errata-xmlrpc 2019-08-28 19:54:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2547


Note You need to log in before you can comment on or make changes to this bug.