Bug 1726949 - Undercloud ntp service was not upgraded
Summary: Undercloud ntp service was not upgraded
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: ansible-role-chrony
Version: 15.0 (Stein)
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: 15.0 (Stein)
Assignee: Cédric Jeanneret
QA Contact: Ronnie Rasouli
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-04 07:23 UTC by Sergii Golovatiuk
Modified: 2019-09-26 10:53 UTC (History)
8 users (show)

Fixed In Version: ansible-role-chrony-1.0.1-0.20190708210510.71b73d6.el8ost
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-21 11:23:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1835368 0 None None None 2019-07-04 07:23:42 UTC
OpenStack gerrit 669365 0 None MERGED Ensure service is enabled 2020-04-30 14:26:08 UTC
OpenStack gerrit 669696 0 None MERGED Avoid hard-coded value in a generic ansible role 2020-04-30 14:26:08 UTC
Red Hat Product Errata RHEA-2019:2811 0 None None None 2019-09-21 11:24:11 UTC

Description Sergii Golovatiuk 2019-07-04 07:23:42 UTC
Summary:

Further information:

Description
===========
Undercloud ntp service was not upgraded

Steps to reproduce
==================
On Rocky undercloud run:

[stack@undercloud-0 ~]$ pgrep -a ntpd
25903 /usr/sbin/ntpd -u ntp:ntp -g

There is a ntp service, configured and running

Upgrade undercloud to Stein by:

openstack undercloud upgrade -y

Expected result
===============
Either ntp or chrony should be configured and running.

Actual result
=============
There are no ntp services running on undercloud.

Environment
===========
1. Environment - Rocky and Stein undercloud.

Comment 1 Emilien Macchi 2019-07-04 20:57:42 UTC
Like I commented in https://bugs.launchpad.net/tripleo/+bug/1835368/comments/1 - I don't understand what your issue is.

Also please share your logs (journal at least).

Comment 2 Cédric Jeanneret 2019-07-08 12:52:25 UTC
Small notes: the upgrade is from osp-14 -> osp-15 on RHEL, meaning there's an OS upgrade from rhel-7 to rhel-8. This involves a host reboot.
The issue is, "chronyd" is explicitly disabled when we deploy osp-14, since we were using ntpd back then. The current ansible "chrony" module doesn't re-enable it, meaning the service doesn't survive a reboot.

The patch linked to this BZ ensures the service is enabled, correcting this issue.

We still have to make it merge, then backport it upstream, and take it downstream for osp-15.

Comment 3 Cédric Jeanneret 2019-07-09 14:21:31 UTC
upstream merged, need to see for downstream backports.

Comment 10 Jiri Stransky 2019-08-23 12:50:03 UTC
Looks good in latest undercloud upgrade:

[root@undercloud-0 ~]# rpm -q ansible-role-chrony openstack-tripleo-heat-templates python3-tripleoclient
ansible-role-chrony-1.0.1-0.20190708210510.71b73d6.el8ost.noarch
openstack-tripleo-heat-templates-10.6.1-0.20190819180520.6a38682.el8ost.noarch
python3-tripleoclient-11.5.1-0.20190731190514.55fe384.el8ost.noarch


[root@undercloud-0 ~]# cat /etc/chrony.conf 
# Do not manually edit this file.
# Managed by ansible-role-chrony
server clock.redhat.com iburst minpoll 6 maxpoll 10
server clock2.redhat.com iburst minpoll 6 maxpoll 10
bindcmdaddress 127.0.0.1
bindcmdaddress ::1
deny all
driftfile /var/lib/chrony/drift
logdir /var/log/chrony
rtcsync
makestep 1.0 3


[root@undercloud-0 ~]# systemctl status chronyd
● chronyd.service - NTP client/server
   Loaded: loaded (/usr/lib/systemd/system/chronyd.service; enabled; vendor preset: enabled)
   Active: active (running) since Thu 2019-08-22 12:11:35 UTC; 24h ago
     Docs: man:chronyd(8)
           man:chrony.conf(5)
  Process: 844 ExecStartPost=/usr/libexec/chrony-helper update-daemon (code=exited, status=0/SUCCESS)
  Process: 758 ExecStart=/usr/sbin/chronyd $OPTIONS (code=exited, status=0/SUCCESS)
 Main PID: 792 (chronyd)
    Tasks: 1 (limit: 26213)
   Memory: 1.9M
   CGroup: /system.slice/chronyd.service
           └─792 /usr/sbin/chronyd

srp 22 12:11:35 undercloud-0.redhat.local systemd[1]: Starting NTP client/server...
srp 22 12:11:35 undercloud-0.redhat.local chronyd[792]: chronyd version 3.3 starting (+CMDMON +NTP +REFCLOCK +RTC +PRIVDROP +SCFILTER +SIGND +ASYNCDNS +SECHASH +IPV6 +DEBUG)
srp 22 12:11:35 undercloud-0.redhat.local chronyd[792]: Frequency -8.092 +/- 0.014 ppm read from /var/lib/chrony/drift
srp 22 12:11:35 undercloud-0.redhat.local systemd[1]: Started NTP client/server.
srp 22 12:11:41 undercloud-0.redhat.local chronyd[792]: Selected source 10.16.255.1
srp 22 12:11:41 undercloud-0.redhat.local chronyd[792]: System clock wrong by 1.376586 seconds, adjustment started
srp 22 12:11:42 undercloud-0.redhat.local chronyd[792]: System clock was stepped by 1.376586 seconds

Comment 12 errata-xmlrpc 2019-09-21 11:23:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.