Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1727012 - [4.2] ClusterOperator cloud-credential missing ClusterStatusConditionType Upgradeable
Summary: [4.2] ClusterOperator cloud-credential missing ClusterStatusConditionType Upg...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Credential Operator
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.2.0
Assignee: Joel Diaz
QA Contact: Oleg Nesterov
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-04 09:14 UTC by Liang Xia
Modified: 2019-10-16 06:33 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:33:03 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cloud-credential-operator pull 88 0 None None None 2019-07-10 19:31:24 UTC
Red Hat Product Errata RHBA-2019:2922 0 None None None 2019-10-16 06:33:14 UTC

Description Liang Xia 2019-07-04 09:14:50 UTC
Description of problem:
Check clusteroperator cloud-credential, the Upgradeable ClusterStatusConditionType is missing.
https://github.com/openshift/api/blob/master/config/v1/types_cluster_operator.go#L135


Version-Release number of selected component (if applicable):
4.2.0-0.nightly-2019-06-30-221852

How reproducible:
Always

Steps to Reproduce:
1.Check clusteroperator cloud-credential's detail.
oc get co cloud-credential -o yaml

Actual results:
ClusterOperator cloud-credential missing ClusterStatusConditionType Upgradeable

Expected results:
ClusterStatusConditionType Upgradeable is there with proper value.

Additional info:
$ oc get co cloud-credential -o yaml
apiVersion: config.openshift.io/v1
kind: ClusterOperator
metadata:
  creationTimestamp: "2019-07-03T03:51:24Z"
  generation: 1
  name: cloud-credential
  resourceVersion: "3381"
  selfLink: /apis/config.openshift.io/v1/clusteroperators/cloud-credential
  uid: d406c3cb-9d45-11e9-945d-023561f97408
spec: {}
status:
  conditions:
  - lastTransitionTime: "2019-07-03T03:51:58Z"
    message: No credentials requests reporting errors.
    reason: NoCredentialsFailing
    status: "False"
    type: Degraded
  - lastTransitionTime: "2019-07-03T03:51:58Z"
    message: 6 of 6 credentials requests provisioned and reconciled.
    reason: ReconcilingComplete
    status: "False"
    type: Progressing
  - lastTransitionTime: "2019-07-03T03:51:24Z"
    status: "True"
    type: Available
  extension: null
  versions:
  - name: operator
    version: 4.2.0-0.nightly-2019-06-30-221852

Comment 2 Oleg Nesterov 2019-07-17 08:39:14 UTC
Verified on 4.2.0-0.nightly-2019-07-17-042929

(openstack) [onest@localhost hive]$ oc get co cloud-credential -o yaml
apiVersion: config.openshift.io/v1
kind: ClusterOperator
metadata:
  creationTimestamp: "2019-07-17T08:09:13Z"
  generation: 1
  name: cloud-credential
  resourceVersion: "18391"
  selfLink: /apis/config.openshift.io/v1/clusteroperators/cloud-credential
  uid: 29e1640a-a86a-11e9-8cd7-0ede0f6a15d4
spec: {}
status:
  conditions:
  - lastTransitionTime: "2019-07-17T08:10:19Z"
    message: No credentials requests reporting errors.
    reason: NoCredentialsFailing
    status: "False"
    type: Degraded
  - lastTransitionTime: "2019-07-17T08:33:26Z"
    message: 3 of 3 credentials requests provisioned and reconciled.
    reason: ReconcilingComplete
    status: "False"
    type: Progressing
  - lastTransitionTime: "2019-07-17T08:09:13Z"
    status: "True"
    type: Available
  - lastTransitionTime: "2019-07-17T08:09:13Z"
    status: "True"
    type: Upgradeable
  extension: null
  relatedObjects:
  - group: ""
    name: openshift-cloud-credential-operator
    resource: namespaces
  versions:
  - name: operator
    version: 4.2.0-0.nightly-2019-07-17-042929

Comment 3 errata-xmlrpc 2019-10-16 06:33:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.