Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1727015 - [4.2] ClusterOperator cluster-autoscaler missing ClusterStatusConditionType Upgradeable
Summary: [4.2] ClusterOperator cluster-autoscaler missing ClusterStatusConditionType U...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Compute
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.2.0
Assignee: Brad Ison
QA Contact: Jianwei Hou
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-04 09:18 UTC by Liang Xia
Modified: 2019-10-16 06:33 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:33:03 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-autoscaler-operator pull 114 0 None None None 2019-08-05 14:08:21 UTC
Red Hat Product Errata RHBA-2019:2922 0 None None None 2019-10-16 06:33:14 UTC

Description Liang Xia 2019-07-04 09:18:57 UTC
Description of problem:
Check clusteroperator cluster-autoscaler, the Upgradeable ClusterStatusConditionType is missing.
https://github.com/openshift/api/blob/master/config/v1/types_cluster_operator.go#L135


Version-Release number of selected component (if applicable):
4.2.0-0.nightly-2019-06-30-221852

How reproducible:
Always

Steps to Reproduce:
1.Check clusteroperator cluster-autoscaler's detail.
oc get co cluster-autoscaler -o yaml

Actual results:
ClusterOperator cluster-autoscaler missing ClusterStatusConditionType Upgradeable

Expected results:
ClusterStatusConditionType Upgradeable is there with proper value.

Additional info:
$ oc get co cluster-autoscaler -o yaml
apiVersion: config.openshift.io/v1
kind: ClusterOperator
metadata:
  creationTimestamp: "2019-07-03T03:53:38Z"
  generation: 1
  name: cluster-autoscaler
  resourceVersion: "4862"
  selfLink: /apis/config.openshift.io/v1/clusteroperators/cluster-autoscaler
  uid: 238cd351-9d46-11e9-84e0-06632ee176f0
spec: {}
status:
  conditions:
  - lastTransitionTime: "2019-07-03T03:53:38Z"
    message: at version 4.2.0-0.nightly-2019-06-30-221852
    status: "True"
    type: Available
  - lastTransitionTime: "2019-07-03T03:53:38Z"
    status: "False"
    type: Progressing
  - lastTransitionTime: "2019-07-03T03:53:38Z"
    status: "False"
    type: Degraded
  extension: null
  relatedObjects:
  - group: ""
    name: openshift-machine-api
    resource: namespaces
  versions:
  - name: operator
    version: 4.2.0-0.nightly-2019-06-30-221852

Comment 2 sunzhaohua 2019-08-06 01:22:55 UTC
verified

clusterversion: 4.2.0-0.nightly-2019-08-05-223032

$ oc get clusteroperator cluster-autoscaler -o yaml
apiVersion: config.openshift.io/v1
kind: ClusterOperator
metadata:
  creationTimestamp: "2019-08-05T05:57:41Z"
  generation: 1
  name: cluster-autoscaler
  resourceVersion: "329962"
  selfLink: /apis/config.openshift.io/v1/clusteroperators/cluster-autoscaler
  uid: efe13380-b745-11e9-998d-02f285780c3c
spec: {}
status:
  conditions:
  - lastTransitionTime: "2019-08-05T05:57:41Z"
    message: at version 4.2.0-0.nightly-2019-08-05-223032
    status: "True"
    type: Available
  - lastTransitionTime: "2019-08-06T01:16:27Z"
    status: "False"
    type: Progressing
  - lastTransitionTime: "2019-08-05T05:57:41Z"
    status: "False"
    type: Degraded
  - lastTransitionTime: "2019-08-06T01:16:12Z"
    status: "True"
    type: Upgradeable
  extension: null
  relatedObjects:
  - group: ""
    name: openshift-machine-api
    resource: namespaces
  versions:
  - name: operator
    version: 4.2.0-0.nightly-2019-08-05-223032

Comment 3 errata-xmlrpc 2019-10-16 06:33:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.