Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1727021 - [4.2] ClusterOperator machine-api missing ClusterStatusConditionType Upgradeable
Summary: [4.2] ClusterOperator machine-api missing ClusterStatusConditionType Upgradeable
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Compute
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.2.0
Assignee: Alberto
QA Contact: Jianwei Hou
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-04 09:33 UTC by Liang Xia
Modified: 2019-10-16 06:33 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:33:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift machine-api-operator pull 369 0 None None None 2019-08-05 14:55:24 UTC
Red Hat Product Errata RHBA-2019:2922 0 None None None 2019-10-16 06:33:18 UTC

Description Liang Xia 2019-07-04 09:33:24 UTC
Description of problem:
Check clusteroperator machine-api, the Upgradeable ClusterStatusConditionType is missing.
https://github.com/openshift/api/blob/master/config/v1/types_cluster_operator.go#L135


Version-Release number of selected component (if applicable):
4.2.0-0.nightly-2019-06-30-221852

How reproducible:
Always

Steps to Reproduce:
1.Check clusteroperator machine-api's detail.
oc get co machine-api -o yaml

Actual results:
ClusterOperator machine-api missing ClusterStatusConditionType Upgradeable

Expected results:
ClusterStatusConditionType Upgradeable is there with proper value.

Additional info:
$ oc get co machine-api -o yaml
apiVersion: config.openshift.io/v1
kind: ClusterOperator
metadata:
  creationTimestamp: "2019-07-03T03:51:37Z"
  generation: 1
  name: machine-api
  resourceVersion: "410252"
  selfLink: /apis/config.openshift.io/v1/clusteroperators/machine-api
  uid: db79466b-9d45-11e9-945d-023561f97408
spec: {}
status:
  conditions:
  - lastTransitionTime: "2019-07-03T03:51:57Z"
    status: "False"
    type: Progressing
  - lastTransitionTime: "2019-07-03T03:51:37Z"
    message: 'Cluster Machine API Operator is available at operator: 4.2.0-0.nightly-2019-06-30-221852'
    status: "True"
    type: Available
  - lastTransitionTime: "2019-07-03T03:51:37Z"
    status: "False"
    type: Degraded
  extension: null
  relatedObjects:
  - group: ""
    name: openshift-machine-api
    resource: namespaces
  versions:
  - name: operator
    version: 4.2.0-0.nightly-2019-06-30-221852

Comment 3 sunzhaohua 2019-08-09 07:42:08 UTC
Vefified.

clusterversion: 4.2.0-0.ci-2019-08-09-034758

$ oc get clusteroperator machine-api -o yaml
apiVersion: config.openshift.io/v1
kind: ClusterOperator
metadata:
  creationTimestamp: "2019-08-09T07:21:19Z"
  generation: 1
  name: machine-api
  resourceVersion: "15785"
  selfLink: /apis/config.openshift.io/v1/clusteroperators/machine-api
  uid: 48853cb6-ba76-11e9-82ce-02d8b9768566
spec: {}
status:
  conditions:
  - lastTransitionTime: "2019-08-09T07:21:28Z"
    status: "False"
    type: Progressing
  - lastTransitionTime: "2019-08-09T07:21:19Z"
    message: 'Cluster Machine API Operator is available at operator: 4.2.0-0.ci-2019-08-09-034758'
    status: "True"
    type: Available
  - lastTransitionTime: "2019-08-09T07:21:19Z"
    status: "False"
    type: Degraded
  - lastTransitionTime: "2019-08-09T07:21:19Z"
    status: "True"
    type: Upgradeable
  extension: null
  relatedObjects:
  - group: ""
    name: openshift-machine-api
    resource: namespaces
  versions:
  - name: operator
    version: 4.2.0-0.ci-2019-08-09-034758

Comment 4 errata-xmlrpc 2019-10-16 06:33:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.